LadyBug GenCumulativeSkyMtx Not working

Hi all,

For some reason my GenCumulativeSkyMtx is not working it returns this message:

1. Download failed!!! You need GenDayMtx.exe to use this component.
Please check your internet connection, and try again!

I’ve check my internet connection and it seams to work just fine. And also I have the latest version of HB an LB.

I’m on Rhino 6 WIP.

Thank you for your help


I’ve check on the Github repo see if I can find GendayMtx.exe and I’m not able to find it…

Is this the way to do it? In the Hydra file the GenCumulativeSkyMtx does not have a working directory input

The error is because the component cannot download gendaymtx.exe file. You can either download gendaymtx manually or install Radiance.

Hi Mostapha,

I’ve veirfy and Radiance is installed on my system. And gendaymtx.exe is present inside the bin folder.

I’ve also replace manualy the gendaymtx.exe with the one on Github, and I get the same result.

thank you for your time

Hi Mostapha,

I’ve installed everything on my system again. And still not able to get LB_GenCumulativeSkyMtx to work I get the same result.

Also. I’ve installed the latest version of OpenStudio 2.1.0 on my C drive and now HB does not recognized. My god!!! I’m so sad I cannot use LB any more. Something is broke…

Any help would be much appreciated


I gave the component a path to C:\ladybug (manually) and it seams to work. Is this the way to do it. If I remember correctly the optional working directory is not necessary.

how to give the component a path

Like so

Kindly setup a profile picture please.

I downloaded the gendaymtx file and connected it to the component but still it’s showing an error is it possible to send you the file to check

Oh you are from Bangalore ,even I am here

Did you put the downloaded gendaymtx.exe file in c:\ladybug?