Ladybug IncidentRadiation 1. solution exception: Attempted to divide by zero

Hi there,

While performing a radiation simulation, I encountered the error reported as described in the title. I checked my radiance version and confirmed that it is version 5.4a. At the same time, my brep is properly recognized and simulated successfully under the old version of the component. For ease of handling, I would like to simulate under the new version of the component. Can anyone help with why the error is reported? Thank you very much!

model.3dm (995.7 KB) (40.8 KB)

Hi @unsev ,

I had not encountered a situation quite like this before but I can see that you’re getting some radiation results of -Infinity:

… and the reason for this is that your geometry is over 3,000 kilometers away from the Rhino origin, which is half the radius of the Earth. It is so far that floating point numbers cannot accurately represent the coordinates of your geometry and it’s resulting in some very strange behavior.

So just move your geometry close to the Rhino origin and you should not have any issues.

Hi chris,

Thank you for your advice. Since the origional coordinates are important in some ways, I used “Move” component to move the geometry close to the Rhino origin. Nevertheless, the same problem occured again.

Furthermore, I checked the version of all five language/simulation engines and their versions all match the information provided by the Compatibility Matrix in GitHub.

Detailed information are attached in the screenshot below. Thank you again for your help!

I have no issues after moving the geometry close to the Rhino origin:

model_correct.3dm (1.1 MB) (26.9 KB)

I guess you didn’t move all of your geometry or something similar.

hi chris,

I opened your files directly but got the same problem as well.
I tried to read the python script, find that the list “total_sky_rad” is empty.
I don’t read python code very well, so I’m wondering what’s going on. sky_mtx component seems to work correctly.

Since the old components still work, I decided to use the old ones first. of course, I would appreciate it if this problem could be solved!

1 Like