Ladybug Installation problems



I understand your concerns. Is it possible to add a userDictionary to the component? Then I can add information similar to this one to dictionary.


Please feel free to forward these issues to me.

It might be something we did with initialization of variables in the ghpythonlib module, an outdated Rhino 5, or something else. I’d like to investigate this.



Giulio Piacentino
for Robert McNeel & Associates



Link on this website is to new Python 6.0.1 and Honeybee require old version 5.101.0. Where i can get old version from>?

Currently it does not work for me?


PS. I found website

and downloaded


Hi Mostafa,
I have the problem as well , when I drag the ladybug ,its color become red and I tried all GHPythons;-( I could not actually work with it .please let me know ii I could solve the problem


Hi Mehrnoosh,

What version of GHPython are you using? You should have GHPython (from here: )



Mehrnoosha and Michal, Unfortunately I can’t reproduce this error. Can you please test the attached file and let me know if it works fine?

As If it still gives you the error can you please open the editor and click on test and tell me what the error is? As far as I can see the error happens in line 35. (54 KB)


Dear Mostafa,
The error of ladybug is " missing member exception"
’ Zuipythoncomonent" object has no attribute, additional help from doc string,
Trace box line 35,
When I tested the GHpython , the msg tells that the python is running fine.


Hi Mehrnoosh,

Did you try the file that I attached?

There are two Ladybug components in the file, and one have the line 35 commented. Does both components in the testGHPython. turn red when you open the file?


Hi Mostafa,
Sry for disturbing you , Could it be related to windows 64 /32 ?
For the the ladybug becomes red and for the other version I attached the pic.
I did not get the point of two component.In the zipped files?


Hi. No problem. Thank you for reporting this.

I don’t think that 32bits vs 64bits is the reason.

Can you try this file and let me know the results. This is the one with two ladybugs and you need to use GHPython…



I just updated to new ladybug and installed new GH but have this error… any help would be appreciated


strange is when I try to add MAth script…can add C#, VB but not python I click but there is no component ?


Quick question Michal, which version of GHPython and Rhino are you running?

  • Saeran


problem was not latest Rhino…I updated Rhino and GH and it works now…thanks



Like others, I had Ladybug running fine previously with earlier versions of RH & GH, but now I can’t get it to work. I tried both the 5.0.1 and the newest 6.0.3 GhPython.gha, can’t get the test files to work. Both Rhino 5.0 (5.9.40609) and GH (.9.0076) are up to date, everything is unblocked using Streams.exe from Microsoft, closed and restarted several times.

The Honeybee icon doesn’t show up either. Your help would be greatly appreciated.



Hi Nancy, Based on what you are saying everything should work fine. Let’s try to debug it step by step.

Have you tested the GHPython component itself? I would suggest to start from there and see if the GHPython component runs fine on your system. You can try something simple like print “hi!” and then press F5 and see if it works. You can find it under Maths tab.



Mostapha, thanks for your quick reply.

You are correct that the GhPython is not working. I reinstalled the older version 0.5.101 and while the test component is not red, it can’t find the Python engine. But I already have Rhino 5 installed, so I am wondering whether it is corrupt or whether there is some incompatibility.

I even emptied out my Libraries and UserObjects folders except for the GhPython in order to minimize the conflicts. Would that cause a problem?

Do I need to reinstall Rhino and GH? Would being on the Zoo make any difference? I plan to switch it back to my own license).



I figured it out. I had disabled a bunch of Rhino plug-ins to make it load faster and IronPython was included. When I loaded it, then the GhPython could work. Thanks for


Where am i suppose to download Gendaymtx.exe from?

I went to OpenStudio and downloaded the Head but I still cant find this file.

What if this site is blocked here?


Hi Mostapha

Doing all these rules on a rhino 5 + latest GH; but still have problem! funny but it works fine on any other computer.Have latest version of python interpreter and ladybug installed but it tells me about missing file!!!