Ladybug Installation problems

installation

#41

Hi AmirAli,

Good to see you here. What is exactly the error on your system? Can you share a screenshot?

Mostapha


#42

Hi,

I fixed it by simply moving to PC:)

There is no exact error. All components have run-time errors prior to using in any definition. While I already have python interpreter installed, it is like a missing of GHpython files.

Ali


#43

And proud to say that I am now using your Bug! in my current workshop. students try to genetically optimize the shape of housing neighbourhoods by evaluating environmental factors. I will write you a report! later.


#44

Dear Mostapha,

I still have the same problem … even unblocking my GHphyton and reinstalling it… what should I do? how can I completely uninstall the ladybug and reinstall it?



#45

Salam. Wonderful! Keep me posted about the results.


#46

You don’t need to re-install Ladybug and Honeybee. The error shows that GHPython is not installed correctly. How do you know that GHPython is installed correctly? Can you drop a GHPython component to canvas with no issues?


#47

Thank you for your reply , Yeah when I drop it , it doesn’t make any changes but when I want to use the ladybug parameters the same error message appeared. an when I opened the file that you’d suggested to Mehrnoush (TestGHPhyton) this it sends me this error


#48

Looks like you’re using and old version of Grasshopper, and/or GHPython. Updating to the latest versions should solve the issue.


#49

wow Thanks Mostapha it worked ! thanks a lot , just in new lady-bug some parameters are different isn’t it? for example in “sun path” component we don’t have latitude,longitude, time zone …


#50

great it works again, Thx!!!

nass


#51

hallo Mostapha,

I am not sure what happened, but the problem appeared when i installed Millipede…i faced the same issues as mentioned here in this discussion, i solved them somehow but still having one issue. in the attached file is a screenhot. can IES file create a problem when creating image?

thx in advance!

nass.



#52

ahhhh, no worries, i just figured it out…

sorry for any inconvenience.

Best,

nass


#53

That worked for me too.

I coundn´t make it work with ghpython 0.6.0.3.


#54

That is likely due to an old Rhino SR. Please update, if you can.

Giulio

Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


#55

Hi all,

I have a small problem with LB&HB, my PC is running lastest Rhino & grasshopper version, python script (0.6.3) work as well. My LadyBug run for the first time as well also, but after I close Rhino and GH, when I open again I can not see any component of LadyBug as you see above.

Someone pls help!


#56

Hi Steve, As far as I understand Grasshopper is not loading Ladybug userobjects. This is more of a Grasshopper issue and Giulio or David should know the answer. Giulio is on this discussion so I believe he will get back to you about this soon.


#57

I’ve seen similar issues with outdated versions of Rhino. Can you really make sure that you have a recent SR: the last one is Rhino 5 SR 2015-2-26?

(go to Help -> About Rhinoceros to check)

Thanks,

Giulio

Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


#58

Hi all,

Thank you for quick reply, I am 100% for sure that my version is the latest one.

Pls let me know how to fix it.

Thank you for your great support!


#59

Thanks Steve, OK, then we can rule out that part.

If you open the attached file, do you read “Python works”?

python-works.gh (2.94 KB)


#60

Hi Giulio,

It works well here!!