Ladybug Installation problems



Ok, good to know. At this point it seems that this is an issue with UserObjects. I will make sure David is alerted regarding it.

EDIT: The issue is logged here.
EDIT2: I would still ask if you are able to copy-paste the Python component. After pasting it, does it still work?


Hi Giulio,

It works perfect now after I did many adjustments last night, and I figured out that’s a very simple issue.

When right click on “component tab” -> creat layout ( i want re-arrange all the components) and save it -> it works well, then i close and restart rhino + GH, LB+HB dont show their components. I must delete my personal layout, leave it as default one and now it’s OK.

So the problem here is made by user ( myself) not by software, then I am sorry for that annoying issue.

I am really appreciate all your supports.

Thank you in advance!

steve DO


I am totally confused!


I’m not sure why this is happening. Maybe Giulio can help. Are you able to use GHPython component in general?


Thanks dear Mostapha
My problem was fixes by using the previous version of GHPython.


The previous one? This sounds a little strange. Are you using the latest Rhino version?

Thank you!


Thank youu!!


Hi all,

So I’ve tried to install LB + HB as it is described in here:….

Step by step. A long time ago I installed it without any problems.
But today, unfortunately, I have a huge one.
There aren’t any of tabs in toolbar menu.
I’ve checked, everything is unlock. (GHPython is working, my Rhino and GH are up to date)
I don’t have any clue what is wrong.

HELP! Please :slight_smile:


Do you have a customized ribbon? I remember that a couple of users had this issue that userobjects didn’t show up in customized settings.


Ok! You are right! Same here! Thank you :slight_smile:




Mostapha, most of my students were able to install Ladybug successfully but one student gets an error message from the Ladybug component. 1.Solution exception: Object reference not set to an instance of an object. Aa with the person above, Rhino GH crashed repeatedly on trying to get the program to work. It has not been possible for us to open the component for editing. Any ideas would be greatly appreciated.


Hi Nancy, This is an issue with GHPython component. Can s/he open and edit a GHPython component? What is the version of GHPython, Grasshopper and Rhino? Are they updated?


thank you mostapha

very useful , i had the same problem and the cause was paython

this one worked for me:


Hi Nina – please don’t use old versions of GhPython today. For your own sake: the code they save might not be forward and backward compatible and they are no longer supported. The only supported one is GhPython, along Rhino 5 SR12 or SR13.


i have Rhino 5 SR 7 64 - bit and install last version ghpython but lady bug not working


I’m in the process of updating all of these delicious tools.

I had an issue using the most current energy plus. What version is working for most now?


Dear Mostapha Sadeghipour

When I closed grasshopper and coma back to grasshopper again for work with lady bug the ghpython. It is not existing.


Go to the components folder and unblock the GHpython.gha file.


Dear Mostapha Sadeghipour Roudsari

Many thanks. It is working