Ladybug new version installation problem

Hey, we ran the ladybug-tools-1-2-0 installer and installed successfully it, but the legacy still remained the old version of 0.069, how that comes?

Ladybug Tools 1.2 are independent of the Legacy versions.

but where can I find the new legacy version of 1.2

i installed it successfully but my menu bar still remained the old one

Can you please restart rhino and gh?

i tried to restart 10 times it doesn’t work

You seem to have installed the latest version of legacy plugins and LBT plugins 1.2. You should have following tabs in grasshopper: LB-Legacy, HB-Legacy, LB, HB, DF, HB-Radiance, and HB-Energy. Which one are you missing?

I have all of them , but LB-Legacy still remained the old version which is the 0.069

All I need to do is wanna get rid of the comfort polygon missing from the psychrometric chart which is from the old version 0.069, now I have ran the 1.2 version installer it said successfully installed but the menu bar still remained the old version 0.069… :joy:

I tried to restart gh and rhino couple times, but it still doesnt work

You should pay attention to what @devang wrote. After installing LBT you have a bunch of new tabs in the menu. The legacy tab is called LB-Legacy and it is the one active on the image you posted. You should look for the Ladybug tab, which corresponds to LBT ( i can see it in your image).

can you pay attention to what I said? all of those tabs are 0.069 version, not the 1.2 version

you have two separate versions installed, parallel and independently from each other.
the legacy version is 0.069 for Ladybug Legacy, and 0.064 for Honeybee Legacy, the new, rewritten toolset is LBT 1.20 that are on separate tabs.

legacy by definition means it’s the old version, that won’t get much attention anymore, it’s functionality is getting transferred, as explained initially in the release notes here:

1.2 release notes here (apart from a few missing features, migration from the legacy version is almost complete):

can you pay attention to what I said? all of those tabs are 0.069 version, not the 1.2 version

if you read again the comments above, what I’ve echoed is already there…

1 Like