Ladybug shadow analysis example file not performing as expected

I’m trying to apply the ladybug shadow analysis example file on a Rhino 5 version on my PC.

I’ve set the context brep as a collection of volumes and the geometry brep as a surface.
My .epw is a local .epw file for Amsterdam.

It should work but I get a flat blue surface instead of shadows. THe legend is blue to red from 0.1 to 1, I’ve also tried 1 to 10, but in any case it’s a flat blue color… Any idea why this is happening?

I’m guessing either something with my model units is incorrect (right now in mm), or something with the grid size is off.

Sadly the forum doesn’t let me attach the .gh or images since I am a new user. How can I attach those…?

Hi @YafimSimanovsky,
Please check this
For the sunlight analysis, please check the direction of your surface. It should face the sun and not the other way around.

1 Like


Thanks for the info. I think the results are better after I flipped the surface.

Still a few questions:

  1. in the tutorial the shadows are black and white, while here I get blue/red… why is that? do I need to set some specific parameters for the legend?

  2. Is there a way (perhaps related to point 1) to ignore the colors on the ground surface and see only the shadows? (458.7 KB) (456.2 KB)

Thanks @devang

The shadows seem much darker from your image. What were the settings you used for the date and time? perhaps they were different than mine? or a different grid size? I used 4 and then 1 but in both cases the shadows appeared a bit weak.

I do have different grid size. Also, reduced the size of the analysis plane so that it’s boundaries are closer to shading geometry. This was done to reduce the number of analysis points. The time period is the same as yours. In your case, you had provided values for high bound and low bound to the legend parameter. I removed that.

I’ve copied your file settings exactly, and I’ve decreased the ground plane size.

Do you have the same resolution when you zoom in on the shadows? perhaps it’s something outside the GH file…?

It looks like some overlap of geometry. Your analysis result is overlapping the geometry? Please turn the preview off for the geometry?

First off thank you for your unknown help. I had a similar issue and this conversation help me resolve it. I do have an additional question, Devang. I have a slope topo rather than flat, how would I generate the context shadow cast on the topo without generating the shadow cast of the topo?