Ladybug Tools 1.1.0 Installation Issue - ERROR: No matching distribution found for queenbee-luigi?

Hi there!

I was hoping someone can provide some advice on the following issue.
I was having some issues with some of the Grasshopper plugins so I decided to do a clean re-install of everything. I had Legacy and Ladybug tools Version 1.2.0 but now I am trying to install version 1.1.0 again. When I follow the installation instructions I get this error:

(Image of the error attached)
Does someone know what this means and how to fix it?
Thanks in advance!!


Hi Mica,
I’m facing the same issue!
Did you find out how to solve this?

Hi Shamlouli,

I basically deleted everything and reinstalled it all again and it worked.

1 Like

Hello @chris @mostapha,
I’ve been using Ladybug tools since a very long time now, and I’ve never encountered an error like this before that @mica.micillo posted about. But now recently i changed my laptop and tried installing LBT the usual way but I keep getting this error no matter what I do. I tried to delete Ladybug tools and then again reinstalling but still this issue is not resolved. Please help. Thanks
Attaching few screenshots of what appears.

1 Like

Hi @Anmol23. Have you tried installing the latest LBT 1.3 version here?

1 Like

Hi @Asisnath. LBT 1.3 runs perfectly but I wanted to use 1.1 due to Openstudio compatibility issues with Ironbug and Legacy plugins that i use at times. Dont know why this issue is only coming now and that too in LBT 1.1.

Ok now one more peculiar thing- LBT 1.3 got installed perfectly but I’m still facing some issue with the HB intersect command.
The error pops out as" 1. Solution exception:Failed to import ladybug_rhino: Cannot import name recommended_processor_count"
Tried to manually provide the processor count still no luck.
I’m assuming all these errors are while installation that bars LBT 1.1 from running entirely and the newer versions to have glitches.
Can anyone figure out what’s stopping LBT to getting properly installed in my machine?
Btw I’m using Rhino 6.3.

@Anmol23 , I have faced a similar issue.
Uninstall and install with admin rights. Some libraries do not load if not being installed under the windows primary account. (assuming you are running windows)

1 Like

You can use separate versions of OpenStudio for Legacy vs. LBT. Just install the OpenStudio that you want to use with LBT in this folder and the Legacy plugin will never find it:


The LBT plugin knows to check that folder first before trying to check the default installation location for OpenStudio. Also, Ironbug should still work with OpenStudio 3.2. If it’s not working for some reason, you should open an issue about it and we’ll fix it.

Long story short, there should be no reason to use LBT 1.1. If there’s anything else preventing you from upgrading to 1.3, let us know and we’ll fix it.

Thanks @chris i’ll try this out. However now Im facing errors even in the installation of LBT 1.3. as I replied earlier to @Asisnath . What @maheshjayayachander suggests didn’t work for me. I’ll post separately for this to avoid confusion.
Thanks once again everyone.

Ok. We also sell single-click executable installers that make installation much easier if you’re trying to install the plugin on a machine that you don’t own. You can get all of the pricing info about the single-click installer by emailing