Ladybug tools in Mac: Problems in the beginning

Hi there,

To start with the tools in Mac (Rhino 5.4 WIP) I faced the following problems:

  1. After putting the user files in the right folder, starting GH led to the following error. But I could continue and LB and HB tools bars are there. Is it a serious problem?

  1. Trying to do my first simulation with HB, I realise that something’s wrong with setting up HB (see below). Does anybody have an idea how to solve this?


The legacy version of Ladybug/Honeybee is not intended to run on Mac. Much like a lot of the software in the AEC industry, you will have to run it on Windows for now. The new Honeybee[+] and Ladybug[+] plugins that are currently under development should theoretically be capable of running on Mac and we plan to fully support this in the future. You can download Honeybee[+] from the food4Rhino page:

Let me know if there is anything that I am missing here, @mostapha.

What @chris said! When we started the development for Ladybug Rhino was only available for Windows and the legacy plugins are developed and tested on Windows so they will be issues here and there in the process. We are fixing this issue for the new libraries and you should be able to run them on Mac.

@farhang.tahmasebi, I know that you’re mainly looking for Energy modeling workflows which are not currently available in Honeybee[+]. We had some fixes to get Ladybug work on Mac but we didn’t have the same for Honeybee. Can you use Rhino on Windows or are you limited to Rhino on Mac?

Finally the import error has nothing to do with Honeybee. The error happens in importing subprocess which is a standard Python library. It is most probably the result of having the Python in your path before IronPython. Can you test this file and let us know the result?

Thanks @chris and @mostapha. I am aware that for AEC software tools Windows is much more reliable.
But the good news is that with a Windows installed via Parallels Desktop on my Mac, GH, LB, and HB worked like a charm. And I am quite happy about this. Because for example the latest SketchUp does not run on a parallel Windows (as it needs OpenGL 3.0, which Parallels Desktop does not support it yet). So, at the moment it is impossible to run SketchUp and OpenStudio on such a setup. But your tools are working smoothly. So my next questions will come soon!
As for your suggestion @mostapha, I was no quite sure how to do it. So, when I find time I’ll get back into it, and report on it.

No worries. That was only the suggestion if we had to get it to work on Mac. Let us know if you have any questions/suggestions.

Hi all,

I’m trying to install ladybug/honeybee on Rhino 5 on Mac.

I’ve downloaded the Honeybee[+] 0.0.03 (2017-Aug-23) install from Food4Rhino, but I’m not sure where to place the folder and sub-folders or how to actually install this in the UserObjects and Libraries or Components folder.

Any suggestions as to the installation steps to make it as usable as possible on a Mac…?


Dear all, I am facing the same problem. I have Rhino3d 6 for Mac installed, and tried running the GH installer for Ladybug tools from food4rhino with little success. Should this work?

Best, Lars.

The Legacy Plugins (that everyone is using at the moment) are Windows-only and they will forever be Windows-only. However, the new plugins that are under development and we are close to officially releasing will be fully-functional on both Mac and Windows. We have been doing testing on both operating systems to make sure this is so. So please hang tight.

Hi Chris,

How soon are we talking, days, weeks? Or after this semester? The next few weeks my design studio is using ladybug for calculating KWh/m^2 and something is off.

I’m using parallels and rhino 6 on a brand new iMac with maxed CPU and GPU. Do I need to turn off OpenGL? Or is it something about the view settings? I had a file that was working just fine and then I changed some view settings and now everything crashes. It worked just fine until it didn’t.

@Jbehre ,

I don’t want to give an exact date but we are aiming for this month. I should also give a disclaimer that not all of the legacy plugin features will exist in this new release, though at least 80% of them will be there and there will also be several new features, especially for energy modeling.

So you’re definitely not going to be waiting till the end of the semester but, depending on what exactly you are trying to do with the software, a solution with parallels might be a safer bet if you can manage it for the time being.

1 Like

Hi -

FWIW, Parallels is not a supported platform for running Rhino 6.

Hi Chris, that’s great to hear. I can’t wait to ditch windows 10 and that stupid chime noise it makes.

I rebuilt my file this morning and tried again and everything worked perfectly, no glitches or freezing. The new file ditched the imported CAD Mapper file for a simplified version that I rebuilt. It’s a very quick program, ladybug/honeybee compared to Sketchup’s Sun Hours.

I think the issue with parallels when I used “coherence mode” where the windows work seamlessly within the Mac OS. Without this mode, you just get a dumb window with dumb windows 10 software and have less room to work with. I work with multiple displays so I thought I’d have one display on GH and the other one Rhino but that seems to have crashed it. So, solved it, thanks for the support lol.

If anyone has this issue, this information may help them, who knows.