Ladybug Tools Installation: Runtime Error (Python Exeption)

Hello, I am trying to install, but when set to true, it gives me the following error:

Did you make sure you had access to the internet? Can you try hotspot from your phone?

Yes, I did have connection to the internet, and there were no firewalls interrupting. IT checked and nothing seemed to be wrong. Is there something else I can do?

Are you using VPN? We use Python’s package manager to install the libraries and I can’t see any issues there. If you are using VPN you should try to turn it off during the installation and that should resolve this issue.

@mostapha I am not using VPN, could it be something else?

Somehow the connection is blocked. You can try to download files from GitHub or pip from CMD and see if that works.

We just had a case like this where someone installed Rhino and selected the option to not allow Rhino access to the internet. Is there any chance that this fits your situation?

Is there a specific GitHub link from which I can get the files from? I can go ahead and try this. @mostapha

@chris I’ll go ahead and try to see if this could also be a problem, but I dont think so because I was able to download other plug ins.

You can find the link to the .zip of the Python installation that the first component downloads inside the component code. However, the second installation component downloads at least 30 different URLs given that it’s installing several Python packages using pip. So my guess is that you are going to face a much more extreme version of the issue that you have with the first install component when you get to the second.

1 Like

2 posts were merged into an existing topic: runRadiance component for daylight simulation

Thank you, downloading the files and placing them on my user folder and rerunning the intall.gh file worked!

I have the same problem and didn’t understand your answer. I don’t have any other .zip folder other than the Ladybug installation zip from Food4Rhino

![image|690x157]


I don’t have any other zip files. Where can I get those zip you mention? (I’m completely lost)