LB Versioner Component causes Grasshopper to crash

I installed ladybug tools 1.0.9 from and wanted to update to 1.1.0 using the LB Versioner component, but when I try to add it to the canvas Rhino/Grasshopper crash and close. I’ve tried a few other ladybug components and I can drag them to the canvas. I’m using Gasshopper build 1.0.0007 and Rhino version 6 SR7 on Windows 10.

Note that my user account is locked down and can’t do anything that requires admin rights. I tried the two steps myself and then had to get help with the “set_python_path.bat” step.

@alexchapin ,

That sounds like an old bug in Rhino 6. I remember there being a few back during the first few SRs of Rhino 6 that McNeel fixed. So you should definitely update your service release and see if that solves the issue.

I remember being recommended to have, at least, SR 22.

Thanks @chris and @AbrahamYezioro! I’ve told IT that I need to update Rhino and I’ll see if that helps. Before now, we only used Rhino to export Rhino models to Sketchup file format, so our knowledge and usage of Rhino is lacking. I’m looking forward to learning more.

I’ve updated Rhino to SR 30 but I’m still getting the same problem. I’ve also asked IT to check if my antivirus is causing problems like this other forum post that I found here.

I just realized that by “crashes” you probably don’t mean that the program actually closes. You just mean that it hangs for a very long time (upwards of a few minutes), which is a different type of situation. I changed the title of the post accordingly but feel free to change it back if I’m wrong.

This looks like your company’s firewall or Virtual Private Network is blocking you from running the pip install commands that are used by the “LB Versioner” component. You have 2 possible options for this case:

  1. Get your company or IT department to make an exception in their firewall or VPN for the Python Package Manager PyPI (aka pip).
  2. Ask your IT department how to pass your VPN credentials along with the pip commands that are being run in the “LB Versioner” component. Hack line 120 of the “LB Versioner” component to include these credentials in the pip commands that are being called:

Or you could just use the stable release.

I do mean that it “crashes” with the program actually closing. By the way, I wasn’t able to figure out how to edit the title of the post. Do your 2 possible options still apply? Also, I’m new to actually using Ladybug, etc. plugins, so are versions 1.0.9 and 1.1.0 not stable releases? If so, should I install versions 0.0.69/0.0.66? I thought that version numbers were typically beta when they are less than 1.0 and stable once above 1.0.

Are there any instructions on how to downgrade? I.E. do I manually delete the files in C:\Users[USERNAME]\ladybug_tools? Any other places? Then install the stable release?

Ah, sorry about that @alexchapin . I put back your original title. I light of that, my two suggestions may still apply but I would say that there’s a lower chance of them succeeding. And I think it’s more likely that the issue is the result of some antivirus protocol rather than just a credential check that is needed to get through a VPN. In order to run the versioner, you’ll probably need to use the same privileges that were used to install the LBT plugin in the first place since the code running in the versioner is effectively the same as that which runs in the

Ladybug Tools version 1.1.0 is now the official stable release of the new LBT plugin. This is a completely separate plugin from the Legacy plugin, which has the versions 0.0.69/0.0.66.

You can always manually uninstall the new plugin by deleting all of the user objects in your Grasshopper UserObjects folder. Then, you’ll have to delete this folder and you’ll be all uninstalled:

1 Like

Thanks for the quick response and helpful information. It looks like I was successfully able to install version 1.1.0, so I’ll just keep that for now and see if there are any other issues.

My IT was able to whitelist the directories in the antivirus program, but that still didn’t help. I think the issue is that my user doesn’t have admin rights, but since it only seems to affect the LB Versioner component, I’ll just have IT manually help me update the plugin as needed. Thanks

1 Like

@chris So, I’ve still been having problems. I’ve also learned that the issue affects more than just the LB Versioner component. I can only open Ladybug files (specifically, I have tried opening the Ladybug sample files in the Ladybug Tools v1-1-0 download folder), but Honeybee and Dragonfly files crash Rhino and Grasshopper. I have even tried installing the Honeybee/Ladybug legacy versions but that doesn’t work either.

Any chance you could give me Early Access to the Pollination Cloud? I really want to use your tools but I just can’t seem to get it to work on my companies hardware.

@alexchapin ,

Is there a chance that your issue is the same as this one?

Honeybee Components Crash Rhino Immediately (Python uuid dependency seems suspect)

Perhaps there’s something wrong with your Rhino’s IronPython.

We have not started Pollination early access yet.

Hi @chris, it does seem like I’m having the same issue with the Python uuid. Hopefully a fix for that issue is found soon. Thanks for your quick response and I hope that Pollination early access starts soon.

The solution ended up being to also add the folder path for the Rhino.exe file to the exclusion list for the antivirus software. I’m glad that it’s finally working and now I can finish learning to use the software. Thank you for everyone’s help!