LBT 1.3.0 Radiance materials

I’m curious if materials on inner walls are correctly setup in LBT 1.3.0.

I’ve used the mod_set as below

however if I open the rad files in spiderviewer, it reveals that my walls and ceilings have the context modifier and the floor has a generic_floor_20 (not my Floors_20). Is this a bug or are they perhaps they are changing between view_mtx and daylight_mtx?

@mikkel @mostapha

@Mathiassn I raised a similar topic here I think:

@TheoA :sweat_smile:


Thats a good point!
Will need to check my rad files manually at work on Monday.

I was using Spider Rad Viewer R7.3

Which is not the newest spider viewer, however it’s the only one I could find that allows me to pick multiple rad files in my explorer :sweat_smile:

@Mathiassn @OlivierDambron

It’s surprising to hear that anybody is using the Spider Rad Viewer. Bravo, I guess!!

Your posts are the first comments in several years.

The RAD Viewer is in the Spider 2021 Viewer: ~ but geometry only.

If anybody is actually interested I could add back the materials etc. in a future release.

BTW, is there a Radiance forum where I could share notice of existence and updates of this viewer?

This is great news, Theo!

What I use it for:
Debugging models and checking I applied the correct materials and normals to correct geometry
It would be nice to see modifiers/materials in the popup, right now I just see color, and it looks like it’s showing same color for all of my geometries (even though they should be differentiated)


in the old one i could view the modifier

There’s the “official” radiance forum here

1 Like

Not sure that it is the rad viewer thats the issue here ( @TheoA ) . the LabelFaces component outputs the following in grasshopper:

Attached the envelope.rad file that also shows that context material is added to all walls even though modifiers should be wall/ceiling.

envelope.rad (11.6 KB)

I think this is a bug @chris

@Mathiassn ,
Your envelope.rad file all seems to be correct when I import it with the Legacy Honeybee Import Rad component:

(blue is floor; red is context)

So it appears this is the same issue that @OlivierDambron experienced and I’d suggest not using the Spider Rad viewer to check materials/modifiers unless @TheoA gets the chance to fix the bug.

@TheoA , it’s possible that you underestimate the usage the Rad viewer gets. @sarith just sent me a screenshot today from the viewer. Also @mostapha managed to convince Greg to move the Radiance email list to a Discourse:

So that would be a good place to advertise the “geometry only” viewer that’s in Spider 2021.



Fingers crossed the RAD viewer gets its materials in a matter of days. I and currently refactoring and streamlining all the various file opening and parsing routines. Adding the materials back into the RAD viewer should drop fairly easily.

Once it’s in I will join the RAD Discourse forum.

1 Like

Chris i disagree.

The setup should automatically put wall_50 on walls and ceiling_70 on ceilings as per the modifier setup in my screenshot. However as you confirmed in the rad, the LBT Daylight setup applies context_20 on my walls and ceiling.


  1. spider rad viewer showed correctly (in my case, not sure about Oliver’s)
  2. the automatic modifier setup in LBT does not apply the right modifiers to walls and ceilings (not floors for that sake, but instead of floor_20, i got generic_floor_20). Please see the modifier setup screenshot above @chris

Tak care

This is a different issue @Mathiassn and it just comes down to how ModifierSets work in Honeybee. Unless you set a Surface or Adiabatic boundary condition to your Honeybee Faces, they are going to be treated as exterior objects. From your screenshot, it is clear that you are assigning the Context material as the modifier for these exterior walls and roofs:


And sorry that I mis-read the screenshot in the Spider Rad viewer. If you say that it’s a true representation of the envelope.rad file, that’s great to hear.

Makes sense, thanks! I’m unsure if adding context on inner walls is ideal though :cowboy_hat_face: since the window edge offset goes outwards, one could assume that this wall is the inner an not the exterior.

But changing to adiabatic should be quickly done. Is that happening in LBT or LBT-Daylight? And, perhaps a boolean toggle in the modifier component could override this for all walls instead of me setting every single one to adiabatic. Just an idea.

And thanks for quick reply :blush:

EDIT: Found the adiabatic component and rewired a few components. Looks ok now :slight_smile: