LBT 1.4.0 can't find path of OpenStudio installation

I think LBT 1.4.0 can’t find the path (location) of OpenStudio 3.3.0 instead it finds the path of openstudio 2.5.0 OpenStudio legacy!
P.S: when I installed both legacy and LBT 1.4.0 they worked properly but today suddenly LBT stop working and it didn’t longer recognize that ope studio 3.3.0

Hi hamed

I had this problem before. I recommend installing OpenStudio in your C:/Users/[USERNAME]/ladybug_tools .


Hi Mohammad, I´ve done so but it doesn´t work. Did you create a folder named OpenStudio or openstudio to install it or just inside LBT folder? It still finds 3.2 even though I change this folder´s name.
Thanks in advance

Hi Patricia

This photo will help you.



1 Like

thnks dear Mohammad
I’ve been read this solution for having legacy and LBT, but in my case, it just works less than a few days.
so I think maybe this problem is caused due by new LBT 1.4.0 or switching between legacy and LBT through different analysis.

Thanks Mahammad!
It works fine now.

FYI, there’s an even more fool proof way to install the LBT plugin and corresponding engines via a free single click installer. You just need to install the Pollination Grasshopper plugin, which comes complete with the LBT 1.4 plugin and a compatible set of engines that won’t conflict with Legacy.

You’ll have to make a Pollination account to get the installer but this will probably save a lot of installation headaches like this:

Hi Chris,

I had the same issue with Open Studio, which moving the OS into the LBT folder didn’t help. For your pollination approach, do we have to uninstall LB completely, or uninstall gh completely for reinstalling pollination to fix the bugs?

Hi @Rob ,

The Pollination single-click installer will automatically uninstall your old Ladybug Tools and replace it with an updated one. The single-click installer really takes care of everything for you.

That worked a treat - thanks Chris!
The only downside is installing Pollination seems to double up all the gh icons, even though I selected to overwrite them (instead of skipping on installation). But they work fine, so I can live with it.

Cheers again!

Hi @Rob ,

That’s an issue that we should probably have the Pollination installer automatically fix for you (CC: @MingboPeng ). In the meantime, you can get rid of your duplicate set of the components by navigating to the following folder:


… and delete all of the folders that start with ladybug, honeybee or dragonfly.