LBT 1.5.0 update failed

Hello chris @chris ,

I’ve tried to update LBT through “LB Versioner”. The note from grasshopper showed, that the LBT have already updated to 1.5.8, but when I reopened rhino, the LBT version is still 1.5.0. The update is under administrator authority of Rhino 6 with “gh installer mode” but not “pollination”.
Before update:

After Update:

Would you please give me a hand? Thank in advance!

Hey @YZZhang ,

It seems likely that this is just a display issue and you actually have LBT 1.5.8 installed. We would know for sure if you have this new version of the HB Custom Ground component installed in your toolbar:


It has a new reset_ option that I just added early yesterday.

If you have this new component, then we can be sure that it’s a display issue and I’ll need to know what the following text file looks like:


If you don’t have the component, then we might need to try some other things to troubleshoot what is going wrong.

Thanks for your quick reply! It seems, that the update is actually failed since no "reset_"option available in my LBT and the version number is still 1.5.0, which is identical to “requirement.txt”.

Hey @YZZhang ,

If you were running Rhino as administrator, then there was a bug with this case that we just fixed a few days ago related to this case:

There’s also another bug that we recently fixed in the Versioner on Mac:

All of this means that it might be worth re-trying this now. Note that you’ll probably have to run the Versioner and restart Rhino twice in order to see the updates.

Thanks for your suggestion,@chris

I’ve tried to retry but still failed. However, “Ladybug.Executor.exe” has appeared for this time and showed the erroe code. Please check the screenshot below:

I don’t konw what’s going wrong but I guess it’s meaningful for you team to find out the problem.

Hey @YZZhang ,

The screenshot is helpful and it seems that your issue is different and caused by the fact that your computer cannot decode the character µ, which appears to be a part of the HTML file from which we read the latest LBT Grasshopper Version number. I just pushed a patch that will enable the Versioner update process to complete on your machine:

The “HB Check Versions” component still won’t display the correct version but you’ll at least be able to get all of the latest components and core libraries after the fix.

Since you won’t be able to get the update with your current versioner libraries, you will have to run the following Grasshopper definition in order to get the fix: (2.7 KB)

After that, you should be able to run the Versioner normally.

1 Like

Thank you @chris, it works!

1 Like