LBT and OpenStudio Fails to Run

Dear @mostapha and @chris,

I have downloaded the latest version of OS (3.2.1) and LBT (1.2.0) and installed on Rhino 7 SR7, but when I am trying to run the energy simulation using the OS engine it pops up an error regarding the version, and when I verify the installations it is sth related to Ruby that seems odd to me and I have no idea what could be the reason. I have tried installing OS on C Drive or C:\Users[Username]\ladybug-tools but still have the problem.


Hi @AMIRTABADKANI . As per the compatibility matrix, till OS 3.2 is supported by lbt 1.2. You can check here

Hi @Asisnath

No that’s not the case… I have tested 3.2 but still, get the same error.
And I guess the matrix shows the minimum requirements not absolute versions.

The compatibility matrix shows the versions that work with certain LBT versions. I think it is an error to think that they are the minimal versions and all versions above them will work. On the contrary. This is what @Asisnath tried to say (i think … :slight_smile: ).

@AbrahamYezioro Yes you rightly interpreted my words :+1:. @AMIRTABADKANI it may happen with some installation issue as you are saying OS 3.2 also doesn’t work.

Thanks @Asisnath, but OS installation is very quick and easy and I don’t see any problem in the process … I hope @chris can comment on this issue.