LBT gbXML Importer

I was curious if there was an estimated timeline for making an updated gbXML import tool for LBT. That is, of course, assuming that it is in the plans to do so. I have some models made in IES VE that I’d like to transfer over to LBT, but I wasn’t able to figure out how to do that well, and I’d like to stick with the new LBT if possible.

1 Like

Didn’t try it but there is a brand new component, LoadGBXML, that i hope does what you are asking for. You need to update with the versioner and restart rhino.

Thanks Abraham,

I ran the versioner and was able to get the component loaded. Unfortunately, when I ran it with the gbXML I exported from IES, I received the following error:

Runtime error (AssertionException): Illegal character “{” found in honeybee object identifier

line 75, in init, “C:\Users\jroth\ladybug_tools\python\Lib\site-packages\honeybee\”
line 26, in valid_string, “C:\Users\jroth\ladybug_tools\python\Lib\site-packages\honeybee\”
line 39, in identifier, “C:\Users\jroth\ladybug_tools\python\Lib\site-packages\”
line 22, in init, “C:\Users\jroth\ladybug_tools\python\Lib\site-packages\”
line 26, in init, “C:\Users\jroth\ladybug_tools\python\Lib\site-packages\”
line 134, in from_dict, “C:\Users\jroth\ladybug_tools\python\Lib\site-packages\honeybee\”
line 151, in from_dict, “C:\Users\jroth\ladybug_tools\python\Lib\site-packages\honeybee\”
line 106, in script

I checked through my XML file and there were no occurences of the “{” character. Do you know what might be causing this error to be thrown?

Unfortunately i can’t help. I don’t use regularly XML files.
Maybe @chris will be able to give some points.

@chris do you have any thoughts on what could be causing this? Thanks!

Hi @jroth93, I had a similar issue. Did you figure out what happened?

Hey Matheus, unfortunately I didn’t yet. Hoping that there may be a fix in the next release. @AbrahamYezioro @chris any updates?

Hi Abraham,

I am new here. Can you please point out where to find this new component (LoadGBXML)?

I am currently using Rhino 6 with Ladybug tools version 1.2 and can’t find any component that can read/load gbXML files.

It is in the Honeybee tab, group 3.
Maybe you probably need to update with the Versioner.

Thank you. It worked!

However, for some models, I still get a similar error reported above:

> (:1. Solution exception:Illegal character “(” found in honeybee object identifier)


I use Revit to export gbXML models. I will check on which export settings I get this error and report back soon.


This issue should be fixed in the latest development version of the LBT Plugin. This is the line of code that should be filtering out all of the characters that are illegal for EnergyPlus and Radiance:

1 Like

Thank you. problem solved!

I am running into another issue with this now where the importer is saying my version of OpenStudio is not up to date (3.3.0) even though that is what I have installed (see below). @chris or @AbrahamYezioro do you know what might be causing this?

LBT uses the OS installed at C:\Users\USERNAME\ladybug_tools. Probably the version of OS there is 3.2.
I assume you installed the OS3.3 manually at the default location (C:/).

My suggestion is to uninstall both versions and the install the 3.3 at the LBT location naming the dir just openstudio.

1 Like

@AbrahamYezioro that did the trick. Thank you!