Lookup folder sees .csv files but it can't be read by "read ep results" component

hi guys
I’m trying to recall some old simulation results from a certain folder and the component keeps giving me the error of
“1. Failed to parse the result file. Check the folder of the file address you are plugging into this component and make sure that there is a .csv file in the folder.
If there is a file with no data in it (it is 0 kB), your simulation probably did not run correctly.
In this case, check the report out of the Run Simulation component to see what severe or fatal errors happened in the simulation.
If the csv file is there and it seems like there is data in it (it is not 0 kB), you are probably requesting an output that this component does not yet handle well.
If you report this bug of reading the output on the GH forums, we should be able to fix this component to accept the output soon.”

I do use lookup folder component and then the “read ep result” gives me the error once I connect it
neither of the CSV files is 0 kB
I’m sure the simulation was ok coz I run it different time for different epw files
and i’m sure i’m using the last update
i tried this with different folders each of which has a different number of zones

too but again the same error
any ideas?

I wrote this component a while ago. Though i checked myself a couple of months ago and it worked fine.
Since the only information you provided is the image, i would suggest eliminating the white spaces in the whole path (there are a lot of them).
If you can upload one of the folders containing the results maybe i can have a look.

by white spaces, you mean the main folders before the one needed and make it

directly ?

0.0-CASH_-NF_1-FH_3.5-CntxtH_3.5-RO_0.0-CasScXY_.5.5-CntxtScXY_.5.5-WR_.2.7z (2.1 MB)

this is one of the folders

The component is actually working. Though it warns not all results can be parsed but the outputs are there.

There are, in the example, 5 zones. I suspect the 5th zone (ZONE 43) needs to be checked (not reporting any results).
Just to be clear, the component i wrote a while ago was the HB_LookupFolder_EnergyPlus, which seems to be working fine. Maybe @chris can confirm what i wrote here?

hi abraham,

i’m sure it’s something i’m doing but i can’t find it
clearly this component had been used several times by me and by others and it was working fine.

and the zero result zone is the core so nothing wrong with it

will try it again with a shorter path may be it will work

Since it works fine now (i tested a new run), i suggest, just to check your case: Can you run it again and see if it works fine?
One thing i noticed in your folder is there were 4-5 CSV files that were created for each zone for Daysim. Maybe they were input files for the E+ simulation. Not sure/Don’t know.
Anyway, i will check this one case to see. I don’t believe the length of the path has something to do with the issue.

@anashosney and @AbrahamYezioro ,
Things were generally working correctly but I found a couple of issues when I went through the workflow. First, I realized that we had not set the E+ lookup folder to correctly identify schedules from DAYSIM (though it was finding schedules that we had made with the CSV Schedule Generator). I just fixed this issue here:

Now it identifies only the results file and not the schedule files so it all works smoothly as expected:

The second thing I noticed is more of a recommendation than an actual flaw but I see that there were a lot of periods in the name of the file and, while this technically can work when the results are in the right place on your drive (like C:\ladybug), it can cause it to be mis-read when it’s on anther part of you machine (like the downloads folder). So, as a general prctice, I recommend using a native GH “Text Replace” component when naming your energy model files to replace the period with another character or get rid of it completely.

1 Like

Very good catch @chris. I didn’t know where those Daysim files came from.
Thanks for fixing the issue.

thank you guys this was really helpful


I have a problem that my read ep results does not have out put

thank you so much in advance

ok, I understand, as @chris said I should use look up energy plus folder.

Hi there,

I am having a hard time importing the Energy Plus results into Honeybee.
I wonder where is my mistake. I don’t know if there is any file missing. I will appreciate if you could point at my mistake.