Louver_count must be greater than 0

Dear @chris,

Would you be able to edit the shades components to allow “0” inputs without throwing an error (maybe just a warning)?

The reason for this would be for running parameter studies; you might want to try different options for shades, including no shades at all.

you can throw an if statement in the component;
something in the beginning of the code like:

if _shade_count_ == 0:
   hb_objs = _hb_objs
elif __shade_count_ = > 0: 
   do the normal things

try this onebypassingShadeCompo.gh (16.8 KB)

1 Like

Thanks @TrevorFedyna, this is a good workaround.

I still think it would be good to allow for a no-shade option in future. It’s nothing new in Honeybee, e.g. the SetEPAirflow legacy component also allows you to select “0” for “No natural ventilation”.

Agreed! @chris, what do you think about this?

Sure. I will try to add it tonight.