Mac Installation Problem

Hello there,
I am having a problem installing Ladybug 1.4.0 on My M1 MacBook Pro, with Monterey 12.0 OS. Following the installation steps and unzipping the python file using Keka app. I am getting an error message saying " “python3.7” cannot be opened because the developer cannot be verified.. There are only two options, Cancel or Move to Bin. If I click on cancel the message keeps coming up again, and the “Standards” folder inside the resources is empty.

How can I get around this error?

Mac has a built-in compressor program that should be able to unzip this without issues.

I’ve never heard of Keka before but it seems like it has some unnecessary limitations to it.

Hi Chris, thank you for the reply.
I tried Mac built-in compressor “Archive utility app” as well as “Oka unarchiver app” to unzip the downloaded python and still getting the same error.

Is it possible to get “unzipped” version if the decompressing causing the problem?

In the event that you just need the .zip file downloaded in a different way to get around your machine’s restrictive security, here is the URL to the .zip file that is being downloaded by that component:

Hi Chris,
Thank you for sending this folder. I still have that error stating that python3.7 cant be opened because the developer cant be verified. I am attaching a screen shot.

I went to the security & privacy of the Mac in the Preference, and while this message appeared, I can click on “Install anyway” in the security window to override it. All “.so” files appeared there sequentially, about 30 of them, and I went clicking install anyway to override these messages one by one, and at the end I got a message that Ladybug has been installed successfully. But when I closed rhino and reopened it again, still ladybug is not there !. Only one image component appears there. In the Install definition, the install component is orange, displaying an error that about 5 “.so” files are missing.

I am not sure why the Mac is blocking this installation. I even disabled the Firewall while installing it, but seems it has no effect.

Any idea what else I need to do?