MacOS Catalina Ladybug Tools Install Issue

When I toggle the second component in the installer on, I am thrown the error: “python3.7” cannot be opened because the developer cannot be verified. I am only given the option to “move to trash” or “cancel”- this is weird however, because I have ran the command: sudo spctl --master-disable in terminal to permanently turn off MacOS Catalina’s horrid Gatekeeper feature. I can hit cancel and then change to “app store and verified developers” in system preferences to be able to allow each portion of the install, but it loops about 3 times for each install file that must be opened and then fails.

Extra info: This is a clean install of Rhino 6 and Grasshopper and I have Python 3.8 installed already.

Any and all help would be appreciated. I was really looking forward to ditching bootcamp just to utilize Honeybee.


Hi @Prxsto, thank you for reporting this issue. This is our first time porting to Mac and it looks like our tests haven’t covered cases like this one.

@MingboPeng and @chris, we have to take a look into this and maybe reconsider building our own Python distribution for Mac if possible. I know we faced a number of issues that led us to building our own but this approach has its own side effects.

Hey @Prxsto ,

I am sure that there is some way around this since I know @MichaelDonn has been able to successfully install it on several Macs running OS Catalina and all of the tests I ran personally were similarly on Catalina.

From the way it sounds, I can think of a couple of explanations:

  1. Perhaps you didn’t unzip the Python download from the first component using the typical archive utility. Just knowing that Windows gives issues if it’s not unblocked before unzipping, something like this might be happening here.

  2. It’s possible that Rhino has not been authorized to to execute commands like “pip install”. I remember when I was testing alternative workflows that involved running she’ll scripts, this presented a lot of issues like the one you described. So that’s why we opted to have Rhino run all of the commands. Since it usually has such authorization because you had to give it such authorization when you installed it.

Edit: Using the MacOS default system utility I was able to install without issue. Crazy how simple of a fix that was. Thanks @chris @mostapha

For point 1: I used Keka to unzip, I will try with the system default. As for point 2: is there any workaround or way to double check the properties of the program like in Windows, where I can grant it admin access indefinitely or manually when run?

Glad to hear that solved it. File compression is a dark black hole of idiosyncrasies but we always test that everything works with the default built-in compression apps on Windows and Mac. So, if you stick to those for Ladybug Tools, you should always be fine.

Hi @Prxsto ,

I’m having exactly the same problem as you describe, but I don’t really follow what you did to solve the problem. I’m trying to install the Ladybug on a MacOS Catalina, and I’ve disabled the Gatekeeper feature and run into the same error code concerning python. Would you mind explaining how you “used the MacOS default system utility” for bypassing the problem, as I’m not a frequent Mac user I did not quite catch that?

Best regards,