Manually downloading LB/HB[+]

installation

#1

Hi all,

Due to company policies I have had struggles updating ladybug[+] and honeybee[+] with the supplied install.gh script.

Quick Fix
Use the attached installer-FIX.gh (14.4 KB). It will do the magic for you, alternatively do the steps below.

Original output:

The error message writes the following:

Downloading ladybug the github repository to C:\Users\mathias.nielsen\AppData\Roaming\McNeel\Rhinoceros\5.0\scripts

Runtime error (PythonException): SystemError(‘The request was aborted: Could not create SSL/TLS secure channel.’,)
Download failed! Try to download and unzip the file manually form:
https://github.com/ladybug-tools/ladybug/archive/master.zip
Traceback:
line 78, in updateHoneybee, “”
line 157, in script

And if you download the above mentioned zip it doesnt reveal where to put it. Nor does it reveal that it needs three more downloads.

Manual Fix

By fiddling a little with the code I found out that a user has to download these four links:
https://github.com/ladybug-tools/ladybug/archive/master.zip
https://github.com/ladybug-tools/ladybug-grasshopper/archive/master.zip
https://github.com/ladybug-tools/honeybee/archive/master.zip
https://github.com/ladybug-tools/honeybee-grasshopper/archive/master.zip

and the content should be unzipped here:
C:\Users<USER NAME>\AppData\Roaming\McNeel\Rhinoceros\5.0\scripts

Hope this helps if anyone else has installation issues!

Tags:
Honeybeeplus HBplus HB[+] installation firewall SSL install server


#2

Only tested on latest Rhino 5 and windows 10…


#3

I think the problem is from github’s side, not due to your company policies. However, the version on food4rhino was before this fix so the HBInstaller won’t work.

Attached is the newer HBInstaller, should work without having to go extra miles.
LBHB_Plus_Installer_032018.gh (6.8 KB)


#4

Thanks for posting this and you are right the the HB+ updater on food4rhino does not have the fixes for github’s new security protocol.

Using the updated gh file posted here will work.

Another option is to use the older HB+ update component but, before you run it, drag and drop a Ladybug_Ladybug legacy component on your canvass. This component has the updated security protocol fix in it and will cause the old HB+ updater to run correctly.