meshParams missing

Hi Devang and Francesco661 !

Having the same error, I tryied to follow to method you were proposing here. But I found something wierd when replacing userobjects… It seems the “_meshParams” input disappear (see image below)

Am I missing something… ?
Thanks you

Hi @CharlesCollin,

Nothing to worry about. That is by design. You will use Butterfly_Blockmesh component to define mesh parameters for the wind tunnel.


Hi Devang,
I have this same problem.

I am at the very beginning of learning Butterfly and I am not sure where I then have to link the ‘meshParams’ of the old ‘createCaseForTunnel’ onto the ‘blockMesh’ component as you are suggesting. This means that I currently have the meshParams (and the ‘gradXYZ’) floating around, not connected to anywhere, which is perhaps the reason why the ‘blockMesh’, although it doesn’t give error, looks like not running (e.g. the black window in Mostapha’s video doesn’t pop-up) and the loadMesh doesn’t visualise any grid whatsoever.

Please is anyone able to help? I check out everywhere I could but atm I am stuck and can’t continue with the tutorial.

Thank you very much, VM

hi viola,

I struggled a bit with that issue too.

If you are using butterfly vers. 0.0.04 and followed @devang post (Installation Error OpenFoam Windows 10 ) to update butterfly to his last version available only on Github, you don’t have the meshparm input in «creatcasefortunnel» component anymore.

You simply have to do the case grading part in the second component (blockmesh). Now if you begin with this plugin, so do I, this is where this new butterfly version is really helpfull. You don’t have to calculate the grading yourself with the gradingXYZ component. Instead just use the butterfly_windtunnelgrading component. It will calculate it for you. (But you can still use the manual grading by plugin it into the _gradXYZ from blockmesh component. (439.4 KB)

hope it helps

Charles C.

OpenFOAM 1706 // VM 5.2.8

Hi Charles,
many thanks indeed, it worked great!

However, now the snappyhexmesh is giving me problems.

First it worked fine and I could run all ok including the solution, but: 1. the folder 1 was not created at all; 2. I couldn’t see the wind vectors and visualise anything while and after the solution ran.

I re-did everything few times, and sometimes snappyhex mesh gives me error: “1. Solution exception:
–> snappyHexMesh Failed!
new cannot satisfy memory request.
This does not necessarily mean you have run out of virtual memory.
It could be due to a stack violation caused by e.g. bad use of pointers or an out of date shared library”

I checked the solution, one is to increase the VM memory, in my case is greyed so not sure how to increase it and couldn’t find online, the second solution would be to purge all and restart, asit may deoend on the blockmesh (even if it ran ok), I did it but it doesn’t look like it works the purge option…

I checked against your file, but they look pretty much the same. Any idea how to solve this please?

Finally, do you perhaps also know if there are other videos (beyond the first 5), showing each component more in detail please? Or how else are you progressing with learning BF at the moment…? Many thanks.


OpenFOAM 1712 // VM 5.2.12

Hi Viola,

The option in VM is greyed out because the virtual machine is running. What you need to do is stop the machine (right click, stop), then go to options and increase your memory and cpu allowance, then restart the machine and OF.

That should do it. A very rough rule of thumb is 1gb for 1mil cells. I would give something like 3-5 gb memory more than the size of mesh I expect though, especially in Windows.

Kind regards,

Great, thank you Theodore, this worked now.