Microclimate analysis "terminated by user" when I didn`t terminate it

Hi everyone!
I am having issues when it comes to simulating my Microclimate Analysis. Energyplus runs fine, Viewmesh runs fine, but the very last step - Microclimate Analysis - keeps getting stuck saying I terminated the simulation when I didn`t. This is a big project and Im just helpless on what to do, I tried everything Ive seen online on such error. Something tells me that theres a chance the error keeps popping since Im not solving adjacencies, but Im not sure how that would make sense. I need help ASAP.
I cant upload here since somehow the file is over the 1.5MB limit, so I hope its okay to post a googledrive link - https://drive.google.com/file/d/1T3X-TLVL_he1pz-OmxIYFT-AinCRsy1t/view?usp=sharing

Currently am trying to run solve adjacencies on all geometries together, but it seems to be too heavy for my machine. Its been running for over an hour.

Update: ran trying to solve the adjacencies on the solar panels and on the floor, separately. Still the same error. I am sorting some things on the analysis period since I read somewhere it could be bugged. If it doesnt work, then I will leave the whole adjacencies running through the night and hopefully will get results. Still clueless on what`s causing this, but updating this as a future reference in case anyone has the same error.

You need to provide access to the above file


Maybe this time it will work?

You need to update your Ladybug tools to the latest version. I can successfully run your file after update. The OS component will update to August 11 2020.

Just Ladybug, Honeybee is okay? I am currently on version 66

Check this

thanks so much! I will check it out and hopefully solve it

oddly enough, it still isnt running. I`m getting the same error. Is there a chance it could be my machine? I will try on my other laptop

The reason why you get this “terminated by user” error is because of a poorly-implemented feature that I added to try to cancel that analysis by holding down the Esc key. I’ve realized that, most of the time, it ends up obscuring the real error so I’m trying to do a much better job with it in the new plugins under development.

Most likely, your issue is that your geometry isn’t playing nicely with the microclimate maps. I know the legacy microclimate maps really don’t handle curved geometry well at all so my fist suggestion would be to make sure there’s no curved geometry in your analysis. If you still get the error after that, upload a minimal version of what’s needed to recreate the error and I’ll have a look.

1 Like

Hi Chris, I redid all my geometry and so far it seems to be working. For some reason Honeybee didnt like very thin, long shapes. Thanks so much for the insight (and for the amazing tool)!

1 Like