No initial residual value

Hello everyone,

I am just starting out in Butterfly’s OpenFOAM, and I managed to get some of the example files running, such as the indoor_airflow, atrium_buoyancy, and hvac. Yet, I am struggling to get the outdoor_airflow-example running properly.

After setting the “castellated mesh” to “false” (the solution runs extremely slow if I don’t do this), I run the simulation with no errors.
However, the Ux, Uy, Uz, and p-values are showing nothing, and upon inspecting my “report”, I see that the initial residual values are all “0”, which might explain why there are no results (at least, when I freeze Mr. Roudsari’s tutorial on YouTube, it says that the initial residual value on Uy is 1 in “Time step = 1”)

I am very unsure as to why this is happening, and hope for any clarification.

It is worth noting that I am running the butterfly version 0.0.05 with OpeanFOAM version 1806 through VM (I am unable to use the blueCFD-version as I am running Windows 7 (it seems other people are experiencing this as well).

I can’t upload the gh definition (as I am a “new user”?), but it is similar to the original in the example files except for the “toggle false” to the “castellated mesh”.

Thanks in advance and kind regards,

  • J

If it’s worth anything, I’ve looked through most of what I could find regarding something similar, i.e. No errors but also no vectors, but without any results.

Hi STUD5801,
you have to put the castellated mesh to True. Explanations of the reason are on the post that you mentioned. Perhaps you could try with refineLevels at: (0,0)
in the BFgeometry component, to run it faster and first check if it works, then if it does, you should increase them. Does it work? Would be good to see an image of what you get…

Hello Viola,

Thanks for your response. To start, I put the “refineLevels” at 0,0.
Then I set the castellated mesh to “true”, but the creation of the SnappyHexMesh still took 9½ minutes! Is this normal? I’ve set my virtual machine to 10GB RAM, and I would have thought this would be sufficient?

When I try to run the solution, the initial residual values remain 0 (except for the Epsilon (E)). After about 14 minutes, the simulation has gone through around 63 seconds, which seems very slow. (535.2 KB)

This time I managed to upload my grasshopper file as I run it (the toggles may be set to true, if you have problems with opening it, I can try to send another file!)

Thanks again for your input!

there are a few things to be adjusted on your file, probably the best is if you first look at this: Mesh settings: BFgeometries-wind tunnel-blockmesh-snappymesh_levels-layers of various type
Hope it helps.