"Number of points in ill files doesn't match the number of points in point files" error

dynamic-shading
annual-daylight
#1

Hello everyone,

I’m testing dynamic shading for a small office room, I encountered this error: “Number of points in ill files: 105 doesn’t match the number of points in point files: 140”. See image below. It’s worth mentioning that I had Windows permission issues (user permission to access the Ladybug folder), I don’t know if this caused the mismatched point count issue.
Here are the files One_office.3dm (76.9 KB)
Dynamic_Shading_Dis_rev5.gh (660.4 KB)

#2

@RaniaLabib, can you share the zipped folder? It’s hard to say without checking the files.

#3

Hi @mostapha, I’ll do that when I go back home to access my computer, in the meantime I found out that my points were split among 3 .pts files, so I have 3 .pts files in the folder. Is this typical?

#4

Are you using 3 CPUs? Honeybee breaks down the points in different files for each CPU and joins them back once the analysis is over.

#5

@Mostapha I was using 4 CPUs, but I’ll double check and report back to you when I go back home!

#6

@mostapha That was it, the number of CPUs, who could’ve known. As soon as I changed the number of CPUs to 1, everything worked perfectly. Also, it solved the problem of not creating .ill files, that I asked about in a separate question.

Thank you so much for your help!

1 Like
#7

hello! im having the exact same issue, how did you change the number of CPUs?

#8

Hello,
I’ve got the same issue but my number of points is negative (-3 by active CPU)
Do you know why ?

#9

@madimas, I’m sorry for the delayed response. You can enter the number of CPUs using a panel and connect it to the runDaylightingAnalysis component. Please see the attached image.

#10

Hi @Mathias, I’m not sure if I understand your question. Anyways, I was able to get over this problem by changing the number of CPUs to 1.