Open foam not working since windows10 updates

Hello everybody,

I know this is not a problem of butterfly, but I think it’s something that many of you may have faced, so I hope you can help me.

My open foam stopped working since the last updates of my windows 10.
We narrowed down to this error.

The IT support of my company told me that it is basically looking for a certificate to install it, but for that it has to access through the port that is highlighted. The problem is that apparently this port is “exposed”, meaning, there is no way the firewall is going to allow it (not even with the antivirus off) as only secured ports are allowed.

My question is, anybody found a way to fix this???


Hi @JuliaT, Did you try the suggestion to regenerate the certs as it is stated in the error message? Also see this:

I’m very close to implement support for bash in Windows 10. That should at least give you an alternative solution.

Hi Mostapha,

Sorry for the so late response.

We managed to solve this problem. I’ve been approached by different people, so I thought I should share what worked for us.

When windows 10 upgraded we had to reinstall Open Foam from scratch.
Then the problem is that to do so, OF needs to download certain files from the specific port that I highlighted in my original post. The problem is that this port is considered “public”, meaning that no antivirus or firewall will allow any download from it.
For the people that work from home it is as easy as reinstall with the antivirus and firewall disabled. For people working in a company, like me, it is more tricky, as they cannot be disabled. We solved it by sending me home to work remotely, where I was not protected by the firewall of my company, as I was using the internet of my home. Then I could disable them and reinstall (to be completely honest the IT of my company did that working remotely in my machine, this became a big problem around here)

Hope this will help


Hi Julia,

Thanks for your post. I’ve tried it both at the office, at home and I’m afraid I encountered the same issues although everything was disabled.

Has your IT colleague let you know of anything else he might have done while handling the issue?


Hi Olivier,

I just asked him and he gave me his notes. Lets see if they are useful for you.


  • Go to Add and remove programs: Install Windows Features - Hyper-V and untick “hypervisor”
  • Give the users local administrative permissions on workstation/laptop
  • Install WinRar to unzip .tar files

Download and Install:
Open foam V1706 (install, all the boxes ticked)
Virtual Box 5.1.30

Use the ‘Docker Quickstart’ to browse to the installation folder using the commands provided.

Then follow this step of the tutorial from the tutorial page ( paying attention to this:

instead of the “v1706” put the number of your version without the “v”, as in windows 10 the folder doesn’t have that V

Follow the installation as in the tutorial and then in Oracle VM Virtual Box
Set VM to use Linux / Ubuntu (x64), if it doesn’t work try Linux / Linux (x64)

And that’s it. With this and updating butterfly everything run again

1 Like