OpenFoam Error in Butterfly (BlockMesh)


I have installed the latest version of BF v3 and OpenFoam v1612… but when I run BlockMesh component in Grasshopper, I get a severe error regarding Openfoam …

  1. Solution exception:Failed to find container id.Do you have the OpenFOAM container running?
    You can initiate OpenFOAM container by running start_OF.bat:
    C:\Program Files (x86)\ESI\OpenFOAM\1612\Windows\Scripts\start_OF.bat

I have read other Issue problems such as #1 , #2 , #3 or OpenFoam Installation instructions but till now I couldn’t run the simulation … I figured out there is sth wrong with my openfoam installation where there should be a container called of-plusv1612-centos66 that openfoam must read it but it can not find it … I checked with docker quickstart terminal as showed in pictures … It could read the image but can not find the of-plusv1612 container …

Do you have any suggestions?

P.S. I have opened all the possible files with or without administrator permissions but wasn’t solved …


Hi Amir,

I think running the container manually should solve it. Follow the last step (and its substeps) in FAQ here.

In case it doesn’t work, try going through the options mentioned here-

Hope it helps.

Hi Saket,

Thanks for your reply ,

No I have tried it many times it didn’t work … I ran Of-Env-Creat and OpenFOAM-Start as administrative still can not run …

And I did what exactly mentioned in installation process … but no result …

I have changed this error message from a couple of weeks ago. Are you sure that you have updated butterfly recently? You need to close both Rhino and Grasshopper after the update.

In any case, just from the images that you have updated there is an error with the OpenFOAM installation which doesn’t really have to do with butterfly. Did you see any errors while installing OpenFOAM? I would suggest to post this issue on GitHub if re-installing didn’t solve the problem.

Dear Mostapha ,

Yes I am sure I installed the latest BF version and I have checked again …

However, I agree with you , it is a problem regarding OpenFOAM installation and has nothing to do with BF … But still after reinstalling OF several times couldnt run the simulation …

I ll post the issue on GitHub … Thanks again


I may be out of focus here, but since this last couple of days i was also dealing with installing issues (successful at the end) i can bring to your attention a couple of points:

If you have a previous installed version, you need to fully uninstall. Including all the items and not only OF. Pay attention also to delete the .docker and .VirtualBox directories at your local C:\Users\USERNAME (see the point before the name).

You need to enable Hardware assisted virtualization at your machine BIOS (personally i don’t like to play with the BIOS but OF asked for it).

After that, do install a clean OF version, and go according to the other recommendations in this link.

It is working for me now on 2 machines (laptop and desktop).

After that remember to run rhino as administrator.

Good luck,


Hi Abraham,

Seems that Mikki found the answer to this one. There is a white space in the user name:…

Also if there is any interest to run butterfly in Dynamo I will have a test version in the next couple of days!

Hi Mostapha,

This is fantastic!! How all things are getting platformless.

Keep going …!!!


This is awesome , You are genius Mostapha … I have changed my username , now I am tring to install again , I ll post my result on Github ASAP … Thanks …

Hi Abraham ,

Thanks for your comment ,

I ve done as you said before but no result ,

now I am trying to rename my Username as there is whitespace within it …

I hope it works


Hi again,

For anyone who had the same issue as mine , I could fix it by changing my username in C drive , there shouldnt be any white space in the user name and if there is, you must delete the user name , create a new one and make it as admin , then everything will be installed fine…

Thanks Everyone

Hi everyone, I’m getting the exact same error although I’m running both softwares as administrator, did anyone find a way to work around?

Hi @Dconforte The image you post is not very clear. Please upload the HD version of the screenshot. And for my experiences, you should use Windows 10 system to run butterfly.

@minggangyin here it is, there is a part in the error which is written in portuguese from Brazil “reconhecido como um comando interno” which means “not recognized as internal command”
Did you guys managed to find a solution for this?
I’m running Blue CFD in the background and executing both programs as administrator