OpenFoam isn't Seeing Geometry: Case Naming

Hi All,

I’m trying to run outdoor wind analysis using butterfly. The issue I was facing is that OpenFoam doesn’t see the geometry although I’ve run blockmesh and snappyhexmesh (snappyhexmesh was super fast to run, making it suspicious, then realised that OpenFoam wasn’t picking up geometry)

I had so many trials in the last couple of days and made sure all geometry is closed. I ended up changing the name in Butterfly_create case from tunnel component and now it seems like openfoam is picking up on geometry and the meshes take decent time to run.

For example, previous naming that would show no geometry
etc… with my various trials.

when I changed the name to
OpenFoam showed the geometry layer

Any idea why that has happened? and is there a certain naming guidance for OpenFoam to avoid future issues?

Many thanks

Hi @Farah.H As for my experience, case name should not be started with any number. As you said, 8888_ProjectName_v01 does not worked but ProjectName_V10 worked.

Hi @minggangyin, yes it seems that this is the issue, name shouldn’t start with a number. Thank you!

Although now the geometry is showing in paraview I still can’t see a geometry file in the case folder

while before I would see a folder for used to see this in the case folder

any ideas?

Hi @Farah.H If you want to view the geometry, you should follow the file path like this:
The geometry is saved as STL file type.

1 Like