OpenFOAM1612+ Installation Challenges


I have problem with installation OpenFOAM 1612+ , the page for OF-Env is like the image below. I use Windows 10 and first Time which I followed the instruction I downloaded v1706 that was ok and installed correctly but for using Butterfly I should have downloaded the 1612+ one.




The latest version of Butterfly on GitHub supports OpenFOAM v1706.

I am having the same issue. Seems like its a problem with starting the VM machine on the system and not with the version of Butterfly? I tried with both OF 1612 and 1706, but still getting same error.

Any solution will be appreciated!

@ApoorvGoyal ,
Make sure that you have completely uninstalled v1706 when you run it with v1612. I have had experiences of OpenFOAM installations interfering with one another in the past. Also, there are generally a lot of nuances to the OpenFOAM installation process and you should make sure that you’ve read everything here:

and watched the complete video on that page.

Chris, I tried all those steps. Made sure that I uninstall everything before getting 1612 installed. Still getting this error:

@ApoorvGoyal Try installing the latest version of VBox, i.e. 5.1.28. Let me know if that solves it. I had a similar issue I believe I fixed in that way in a PC I hadn’t used BF on for a while.


I updated the VM Machine. Seems like partially its a problem also with the security settings on windows 10 in the office. If I get the IT to run OF_Env_Create as a “Super Admin”, it does not give me the error about VM Box, but it still is not able to start the Default VM.

So the earlier problem was to do with a security setting on the system from IT. I got past that, but now when I run “OpenFOAM Start”, there is an error that stops the running VM machine. Restart is not helping.

Apoorv, You need to follow step 2 on this page. Also the latest version on GitHub works fine with the latest version of OpenFOAM.

Thanks Mostapha,
I tried that as well. It actually starts the “default” machine, but the OpenFoam Start shuts it down with the same error.
Below is the snapshot from the Docker QuickStart Teminal window:

Is it because of the read write access?

It does say “Read-only file system.” It looks like that is causing this. Also, did you try “power-off” in VirtualBox Manager? and then turning it on again?

Yes, I am able to Power Off and Start the VM from the VirtualBox Manager. But as soon as I open the “Start OpenFoam”, it shuts down the VM.

You can try to reset your computer again. And use the method shown below.

Find “Docker Quick Start Terminal” on your desktop and double click on it. If you get an error message, right click and select “Run as administrator”. You should see a black window with “Start interactive shell” in white text. Once you have this window, type the following commands and hit enter after each line item:

**cd /c/ **
cd 'Program Files (x86)'
cd ESI/OpenFOAM/1612/Windows/Scripts
docker load -i of_v1612plus_centos66.tar //version 1612

Thanks, I have already tried restarted several times.

Solved everything finally! I re-did the last step that @minggangyin mentioned for the third time. It worked this time. Another problem was that although I had the admin account on my user name, i still did not have the local admin rights, and therefore was not able to read write in certain folders.

Thank You everyone!


@minggangyin - thanks for your help 1 year ago I’m trying to install without success and your steps helped me a lot

1 Like

@vinicius_petrucci You are welcome.