Openstudio can not recognized in Honeybee leacy, but recognized in HB newer version


I have some confusion with my HB-Legacy version because it does not recognize the pen studio. I tried to change many times the repository installation (from C:, to C:/program file, C:/program(86x), C:/Users), but it still can not read my open studio.
I used the latest version of Openstudio as well.

However, the strange things, the newest version of HB can read my openstudio, and I do no have any trouble to execute any process in it.
I can not find any discussion about this before, and I tried to follow the previous discussion regarding the HB installation, but it still does not work.

Perhaps, Is there anyone who facing the same problem and can solve this?
Thank you, I am also put the PC of my HB.


Hey @Aulia ,

If you installed Ladybug Tools using the Pollination single-click installer, then the OpenStudio installation will be within the C:\Program Files\ladybug_tools directory. This frees you up to install an older version of OpenStudio for Legacy in it’s default location in C:\OpenStudio-2.9.1.

FYI, you can always see where the LBT plugin has found your OpenStudio installation using with the HB Config component.