Openstudio error

Hi everybody ,

hope you are well , I updated LB & HB but unfortunately, Hb can’t recognize Openstudio , it’s asking to install the latest version . the latest version of openstudio 1.12 is compatible with energyplus 8.5 but for HB we need energyplus 8.4 , so I installed openstudio 1.10 which is compatible with energy plus 8.4 but I have the same problem. Also I checked the openstudio files on LB folder (on my system) and unblocked it .

I hope you can help me solving this issue ,

Thank you ,



You don’t need to worry about installing E+ for Honeybee if you install OpenStudio correctly. OpenStudio includes a compatible version of E+ and Honeybee knows to use that one if it finds OpenStudio. So you are better off installing the latest OpenStudio.

In any case, check to see if you have this folder:

C:\Program Files\OpenStudio 1.12.0

…or, in your case, this folder:

C:\Program Files\OpenStudio 1.10.0

If you don’t have at least one folder of this variety, then you do not have OpenStudio installed in the correct location on your system. Try installing again taking the default install location.


Hi ,

I installed energyplus 8.5 with openstudio 1.12 " the latest versions " but still have the same problem , what should I do to solve this problem?

Thank you

Is that folder in the location that I suggested you check?

Hi Chris ,

Thank you so much , I reinstalled openstudio in the right location . Now it’s working .

many thanks ,


Hi Chris you seem to know how to install openstudio quite well,

My HB just cannot find open studio, if you know why? I tried at both C:\ and C:\Programfiles and both doesnt work…

Screenshot in the following link that i posted, thanks…

Did this ever get resolved? I receive the same error message about not being able to find OpenStudio when I installed it under C:\OpenStudio-2.3.0 and then removed it and reinstalled it as C:\openstudio-2.3.0 I updated Honeybee to 0.0.62. Any ideas would be appreciated.

For the record, this problem has always been resolved but OpenStudio releases a new version every 3 months, so people using older versions of Honeybee need to update their Honeybee components if they want to run the latest versions of OpenStudio. Alternatively, they can use an older version of OpenStudio with their older Honeybee.

Older versions of OpenStudio can be found on the NREL github:

As I said in the email, @NancyYenwenCheng, your Honeybee components are likely too old to use OpenStudio 2.3. Update your Honeybee components to the latest version on the github and it will work.

Also, I should make it clear that you should always install OoenStudio in the default location. This location has changed across the versions of OpenStudio but the Honeybee component searches this location to find the installation of OpenStudio.

Hi Chris,
My HB just cannot find Openstudio, if you know why?
I have installed latest Openstudio at a both C:\Program Files\ and C:, but doesn’t work

Hi -

If you insist on using the legacy version of Honeybee, you’ll have to install an older version of OpenStudio.


1 Like