OpenStudio executable not accessible with ucrtbase dll error?

I also have the same problem. “1. Solution exception:An OpenStudio installation was found at C:\Users\sn\ladybug_tools\openstudio\bin\openstudio.exe
but the OpenStudio executable is not accessible.
unexpected ucrtbase.dll”

Tried uninstalling and reinstalling the entire Ladybug tools set. The only thing I can think of now is to uninstall and reinstall Rhino, which I am trying to avoid unless it is absolutely necessary.

  • HB Check version shows open-studio empty while HB config shows it in the folder.

What am I doing wrong?

Hi @SuNa ,

I moved your question to a new topic because it’s a different issue, even though the error message is similar.

You are getting this message because you are using a Mac computer (I’m assuming running Windows on Parallels) that has a different computer chip architecture than what the rest of the industry is using (a very Apple thing to do if you ask me :upside_down_face: ). The version of OpenStudio that you have installed was not built to work with this chip architecture but, @edpmay found this issue over a year ago and let the OpenStudio team know about it:

They have since released versions of OpenStudio that work with your chip architecture. So just make sure that you are using the right version of OpenStudio specified in the LBT compatibility matrix and you should have no issues:

Thanks, @chris for your response and redirecting to the previous post.
I did check the compatibility matrix before downloading the Mac and Windows versions of OpenStudio but the error remains the same. I checked the thread on Github but I still don’t understand the solution, probably due to my lack of experience in this subject. Waiting to hear back on the thread. Meanwhile, trying to use Rhino/Grasshopper on Mac OS:

P.S.: Big fan of your work!
Also, I feel sorry every other day when I have to use Windows on Mac for Grasshopper.

Hey @SuNa ,

OpenStudio 3.5.1 should have the fix. Is that the version that you installed and the version that the HB Check Versions component tells you that you are using?

yes, but the problem persists.
@macumber replied to my request on GitHub and OpenStudio works on Mac.

I am still receiving the ucrtbase.dll error on Windows. Couldn’t figure it out yet and installed the 2022 visual ++ in the hope of some solution. But that also didn’t work. So now I am trying to work on the Mac version. However, I am facing new problems with HB UTCI and I will request support on it in a different, already existing thread (UTCI Comfort Map Failure on "ComputeSpericalViewFactors" - #12 by chris).

Hi @SuNa ,

Glad that @macumber answered your question over there on the OpenStudio GitHub and sorry that I misunderstood the solution they had implemented. It seems that you will have to do your work on your MacOS side and a solution for Parallels is not supported.

We will get to the bottom of the UTCI comfort map error in the other post that you linked to there.

1 Like

Hi there,

is there now a solution for that problem ? Or still not possible to use radiance on parallels?

I’m using a lot of plug-ins that are only avaiable on windows (win11 on parallels), so i really need to solve that, would be great to hear from you :slight_smile:

Hi DomiMi,

The last time I checked, it still didn’t work. But now I have switched entirely to Mac Rhino. So unsure if it has been updated.


yes, thats a good idea. But not suitable for me because i need plug-ins like Karamba3d, that are only avaiable for windows. So i am a bit helpless.

My original understanding is that Radiance should not have issues running on Parallels and that the issue at the top of this post is about OpenStudio. But I now see that both OpenStudio and Radiance have dedicated Mac installers for computers with ARM chips:

OpenStudio Installers

Radiance Installers

… and there’s no Windows installer for machines with ARM chips since practically the only place you’ll find this situation is Mac laptops running Parallels.

We’ve tried to do the best that we can on our end by natively supporting Ladybug Tools on Mac. Beyond this, I would suggest that you purchase Macs in the future that have an Intel chip instead of an ARM chip in them if you want to run Parallels on your Mac.

But I’m not sure what else we could do for this situation except to admit that there’s a price for living in the walled garden of Apple. It’s a beautiful garden for sure. But it definitely has walls.