OpenStudio measure Run In Background Issue

Hi, In OS Measures encountered to error run in Background and doesn’t work neither with Openstudio component nor with Apply OpenStudio Measure component.
Is there something that I am missing? or it is a bug.

It looks like an outdated component. Try to update whole definition using ladybug icon without dots. This should work. :slight_smile:

I’m aware of the update, It was just an example. Nothing changed. I checked that in latest version before too. Thanks.

Is it bound to one file? Have you tried to do the same thing or something similar in new file?

I took one of my old file and I tried to do that background run and for now it is going so I guess it is working. All I could try to suggest now is to troubleshoot it component by component. First take your OS component and disconnect all the inputs leaving only HB Zones connected. Then take HBZones straight after adjacency component, put it into OpenStudio simulation and try to run it. If it work - go to whatever you’ve got next. Let’s say glazing or something - put it into OS, and probably at some point simulation is going to break - then you know where the problem lays. If the issue will come straight after first component with HBZones (as I said before - probably adjacencies) the problem probably lays in OS block.

@Avik, To clarification, the issue is actually related to Measures and not about Openstudio Component itself.

what happens if you use a new component to reload the measure?

@mostapha, Everything works fine except option 2 (Run in Background).
And, reloading the measure by using a new component was successful.

ps, This time I opened @Chris 's Example to make sure about the issue in option 2.

1 Like

Thanks for reporting! @chris is the right person to answer this question.

1 Like and @Avik ,

Thank you for finding this issue and I apologize that it took so long for me to address it. I just fixed the issue with this commit:

… and there should now no longer be any issues with running measures in the background.

1 Like

Thank you for fixing this @chris .

@chris, I tried to test components after the updating. But one of the components has the previous error yet. Honeybee_Apply OpenStudio Measure ,
I forgot to fix it in the Apply OpenStudio Measure component (I only fixed it in the Export To OpenStudio component). Thanks for checking and I will fix it in the Apply Measure component shortly. ,
This has been fixed:

Thanks again.