OSM to gbXML makes blank?

Hello all,

I’m trying to use HB to get zone geometry out of Rhino into a gbXML. I’m using the “OpenStudioToXML” component but can’t get it to output an XML. (Is it true that grizzlybear isn’t current anymore?)

When I wire up the component, it returns “true” from the success port, and “File exported to: c:\temp\sim” from the readMe! port. Looking good. BUT there’s no sign of an xml file in the Windows folder!

Just to check, I …

  • made sure the OSM simulates successfully (it does).
  • opened the OS gui and exported the gbXML from there. That works. (and provides a path forward.)
  • done the whole rewire/disable/enable/updateHoneybee/unload-loadGrasshopper rain dance in different ways.
  • also checked in the default LB/HB paths.

But it still doesn’t appear to generate the file. Any thoughts?

@NickNovelli ,

I can run the component without issues on my end. Are you connecting up the inputs correctly to the component as you see in this part of this hydra example?


Are you able to run that Hydra example at all?
If you are able to run the hydra but not your model, then the issue is likely with how the openstudio model is set up and you should upload a .gh file that re-creates the error.

Thanks Chris! Works now. It was my silly error - I didn’t include an actual file name in the file path, just the directory. This is a good reminder to me to look to Hydra for examples - LMHTFY?