Outputs missing in "Read EP Surface Result"


#1

Hi there,

I’m learning to use the Read EP surface Result, but the component seems to lose the output. Can anyone figure out what the problem is?


And my file is attached here.
read EP Surface Result…WH.gh (574.5 KB)


#2

Without checking your file please check you are using the EPOutput component and if so you set any input on it.
-A.


#3

Do you mean I should use the RunEnergyPlus instead of ExportToOpenStudio?
By the way, when I use the RunEnergyPlus, the ReadEPSrfResult still can’t work well, the error is here:

  1. Failed to parse the result file. Check the folder of the file address you are plugging into this component and make sure that there is a .csv file in the folder.
    If there is no csv file or there is a file with no data in it (it is 0 kB), your simulation probably did not run correctly.
    In this case, check the report out of the Run Simulation component to see what severe or fatal errors happened in the simulation.
    If the csv file is there and it seems like there is data in it (it is not 0 kB), you are probably requesting an output that this component does not yet handle well.
    If you report this bug of reading the output on the GH forums, we should be able to fix this component to accept the output soon.

Thanks.


#4

No. I meant the HB_EPOutput component, where you set the outputs you want to calculate.
You can upload your file here so people can help better.
-A.


#5

sorry for miss your meaning, I have found where my problem is. thanks Abraham!