Plenum Zones in Ironbug

Getting into Ironbug and really enjoying it so far.

Had a question about how to incorporate plenum zones, especially if they are part of the return air path. Please let me know how they should get assigned in this case.

Hi @Elliot_Glassman

Plenum has not been included in current version . But please install V0.0.9 ( with (211.6 KB) (this plenum will be added in Irongbug Preview release in April)
Note: make sure unblock both zip files after you downloaded them.

Once you installed the v0.0.9 and add-on package, here is an example.
20190314_ZoneWithPlenum.3dm (142.0 KB) (545.0 KB)

Please let me know if you have any questions.


Awesome, I will try it out and let you know if I have any questions.

I am not sure I could overstate how excited we are to be learning what we can do with this plug in.

Followed the steps to update, but getting a long series of loading errors and most of the components are missing


Did you unlock file after you downloaded?
Did you unzip this file to C:/Ironbug folder to override the same files from v0.0.9?

Could you open one of errors to see what actual error is?

Hi Mingbo,

There was no button to unblock, but we figured out that was a function of our IT settings. We figured out a workaround by copying them to a USB ;). Thanks for your help, the components load fine now.

Using the save OS Model component, our system is beautifully represented in open studio.

However, when I try to run the simulation in Grasshopper, I get an error in the export to open studio component: 1. Solution exception:772c29db-b7a7-42a3-8f5f-8ecea9ac5a51

Any ideas what causes this?

From the screenshot, I cannot really tell what the real problem is.
My only guess is the spacing in study folde’s name, EnergyPlus might don’t like it.

Did you try to run without HVACSystem?

Actually I found the solution. I had both OS 2.5 and 2.7 on my system. Once I changed the folder name of 2.7 to hide it from Honeybee, it ran wonderfully. Thanks!