Problem lbt_recipies


I am trying to run a basic shoebox model on my computer, and I cannot seem to get honeybee to work with me. In particular the component HB Annual Loads has a problem. Here is a screenshot:

It says “1. Solution exception: Failed to import lbt_recipes: No module named lbt_recipes.version”. I often get problems with honeybee and ladybug on my computer. I have suspected that it has to do with the python build that I use and/or how my programming environment is setup (I have the latest conda distribution of Python 3.9 installed with additional dependencies for the Unbuntu shell that I run on my Windows). Usually when I encounter problems, a clean install and updating honeybee and ladybug seems to do the trick, which I did this time. I have reset the path variables, as well. However, it has been to no avail. Does anyone have any suggestions? Can I manually download the lbt_recipes folder? If so what filepath should its destination be? Thank you!!

I had the same issue with version 1.2.0, downgraded to 1.1.0, now the error is gone and It’s working for me so far.

There’s definitely no need to downgrade, @lukasl

When you update your installation (via the for 1.2.0, the LB Versioner, etc.), only the components in your toolbar will be updated. All of your Grasshopper definitions still have components with the old version numbers.

You have to run the “LB Sync Grasshopper File” component to sync the version of the components on the canvas with the version that you have installed.

Then, everything should work unless you have a Grasshopper definition with the (rare) case that the component changed so much that it could not be automatically adjusted. In that case, you will see the component circled in red and you will have to manually replace it.

Let me know if that also solves your issue, @maxhakk . I can (almost) guarantee that the issue is not with your PATH variables or your connda distribution. Ladybug Tools has a completely separate Python version and we always call it explicitly (without relying on PATH variables).

1 Like

Hi, I this have the same problem with “Failed to import lbt_recipes” after installing version 1.2.0 on Mac.
I have done the “LB sync” and looked in lib folder for lbt_recipes and its there.
Any ideas how to solve this?

I have the same problem with the 1.2.0 on Mac, I had to use Windows and 0.5.6 version.

Good catch. There’s a bug in the 1.2.0 Food4Rhino installer on Mac. I will update the Food4Rhino installer now with the fix. In the meantime, running the “LB Versioner” on Mac with 1.2.0 plugged into the component should fix your current installation, @jarkko and @Eric348 .


Ok. The Food4Rhino installer also has the fix now so another option is just re-downloading the installer and running the second component.

hi @chris

I also ran into a similar issue, even after re-installing using the latest files from Food4Rhino.
Could it be because of grasshopper looking into the wrong folder for the ladybug libraries?

In this folder I don’t see any grasshopper plugin:
/Library/Application Support/McNeel/Rhinoceros

while in this one I can see the plugins:
/Users/olivierdambron/Library/Application Support/McNeel/Rhinoceros

hi @chris

just wanted to report that I found the solution to my issue.

When installing LadybugTools via the installer on MAC, the instructions are to be followed as per 1.2 Mac Installation Steps · ladybug-tools/lbt-grasshopper Wiki · GitHub

However there is one detail to stress that some may find useful when working on MAC.
At step 5. “Restart Rhino…”, we need to make sure to Quit rhino properly rather than just close the Rhino window before re-opening. For those encountering this issue, make sure that you don’t have a dot below the Rhino icon in the bar menu, before relaunching.
Screenshot 2021-05-11 at 23.29.47
All is working for me now.

Perhaps it could be a precision to add on the wiki.