Problem with set ep airflow component


I´ve been trying to run an energy simulation of an office (using natural ventilation) with the “set ep air flow” component, but since i updated my honybee version, the “run energy simulation” component fails to run the IDF. The balloon message says :

  1. The simulation has not run correctly because of this severe error:
    ** Severe ** Out of range value Numeric Field#3 (Effective Angle), value=360.00000, range={>=0.0 and <360.0}, in ZONEVENTILATION:WINDANDSTACKOPENAREA=ZONE_0NATVENT2

How could i solve this problem?

Thank you all for your attention!

Imagem inline 3

This looks like an error on our side. Reading the EnergyPlus error tells me that we need to use 359.9 and not 360 for the input. I added this to github ( and we will get back to you soon. Thank you for reporting.


This was indeed a bug resulting from a small edit I made after the last stable release. Thank you for reporting it. It is now fixedon the github:…


hello everyone
i am working on early stage optimization and start to model a simple room for testing EUI. in this way i used some default setting for construction…
it is so weird that when i add natural ventilation by using (set ep airflow)to my modeling EUI will increases.
here is my setting for this component:
cooling set point:26
heating set point:19
nv type:1

How can i solve this problem?

thank you for your attention