Problem with text legend

Hello everyone,
I have a visual prolema that heavily slows down the rhino viewport when I activate a ladybug component that includes a legend.
From the images that I am attaching, it seems that each letter is made up of many colored surfaces.

Anyone have ideas?
Thanks so much

Hi,@MassimilianoBusnelli It is normal. Maybe you have baked the text and legend to rhino, so the legend and text are meshes.Please upload the full screenshot of your grasshopper.

Hi @minggangyin ,
thanks for your answer. Unfortunately it happens to me with all the display components of ladybug. I’ll post the image and the .gh file
The real problem is that the viewport of rhino is slowed down so much that I can no longer even turn the models formed by a simple box, or as in the case of the image the simple ladybug skydome (over 10 minutes of clock for these images!). It had never happened to me before … (386.1 KB)

thank you very much

@MassimilianoBusnelli Your grasshopper file worked fine on my computer. I suggest you to use Rhino 6 SR 12 or newer version. And you should have a 2G-RAM graphic card for rendering.

Thanks @minggangyin ,
I have often used Rhino and Grasshopper with Ladybug on this machine, never had problems … I don’t know what I have combined, maybe some updates …
I am using Fusion on Mac to use Rhino with Windows. I try on another pc.

@minggangyin I have update Rhino to SR24 and I have set in Fusion over 2 Gb graphic card. the problem is still there, perhaps it is due to some visualization setting or the like, but it is no longer usable, the refresh of the viewport is too slow. Any help are appreciated!

Hi Massimiliano - I’m afraid that virtualization systems on macOS are not supported.
Have you tried running Rhino on macOS?

Hi @wim,
I tried with rhino on mac, the skymatrix does not work (because it makes a run of an .exe file not supported by the mac) and therefore all the solar analyzes. I tried to insert a .mtx analysis in the directory, but this doesn’t work either, it doesn’t read the path well because on windows use / instead on mac \ … Hopefully a Mac version will come out! I book for betatester !!!

Really there is no possibility, instead of the text for mesh, to have a text for font? So as to bypass the problem even in virtaulization?

Best regards!

Hi Massimiliano -
Have you tried running Rhino in Bootcamp on the Mac?

As for bypassing mesh-text issues, it’s probably possible to completely bypass the creation of legends by editing the script in the component but that’s something that perhaps @mostapha could comment further.