Problems with Butterfly - won't simulate proberly


Can someone figure out what is wrong?

I have uploaded my files, in case it is fixable.

Kind regards


Masterplan simulation in meters.3dm (959 KB) (427 KB)

Hello grasshopper Forum

The first message, was a little bit thin in its information about the problem and i apologize for that. It had been a long day and night, which lead to a frustrated and short message. Anyhow I really like your opinion upon the problem.

I have tried for someday to simulate an outdoor wind flow of my own rhino model (Importet from sketchup). Beforehand i went through a tutorial of Mostapha Sadeghipour Roudsari, and everything worked during that tutorial with a provided grasshopper example file for this situation of an outdoor simulation.

Then I tried to simulate upon my own, and got everything to work just fine until the Solution component from Butterfly. Suddenly my Rhino model disappeared and I wasn’t able to see if it was working. Still the Solution component was still running, but without any visible content in Rhino.

What could have gone wrong?

Kind Regards

Hi Christoffer,

I’ll go through your model today and let you know if I find something.

The fact that the simulation is running while Rhino has dissapeared sounds like Rhino closed with some error but the VM was still running (it does that, even after we close the docker window).

I’ll check the file and see what I find.

Kind regards,


Thanks Theodore!

Christoffer, Can you share a screenshot on how does it happen? Is it minimized somewhere or is closed / crashed?


Maybe i didn’t formulate myself properly, but Rhino does not crash or minimize, but the 3D model inside Rhino disapears and I can’t see the simulation visualization.

But thank you guys, really appreciate it!

Kind regards


Hi Christoffer,

I opened your Rhino file and there are two issues:

  1. The units are in mm which doesn’t seem to be right. The heights of the buildings are 12 units.

  2. The model if way far from the origin (0, 0, 0).

Fix the scale and move the model closer to the origin and that should help you to solve the problem.

Hey Mostapha

I actually made it work, thank you!
But it still seems that my 3D model dispears except from the perspective view. Any solution to that? I would like a some good views for picture, to document the wind flow.
I have attached a screenshot.

This is probably because you’re getting some values out of scale and the vectors are so large that makes your geometry not to show up. The reason for that is most probably because some of the “probes” are not inside the solution domain. Make sure none of the “probes” are located inside the buildings.

I haven’t been able to find my model in the Rhino views, it only returns when I end the simulation.

Furthermore I tried to keep on the simulation and got something out of it! But I would like the Legend to be visible as well, which I can not. Any solutions to how I can?
I have attached a screenshot, of how it looks like, when I have set the component to preview.

Thank you!

Can you share a cleaned version of your file? That way it will be easier to help.

Thank you for taking the time to help me Mostapha, you are to kind.

I have attached the files. (429 KB)

I could only upload them one at a time…

Hjulmagervej.3dm (2.66 MB)

You need to clean the Rhino file. There are objects far from the origin in the file and Rhino has a hard time to render the views. I copied only the buildings that you need for simulation in a new file which is attached.

Two more comments:

  1. You can union all these geometries into 4 clean closed polysrf. Use BooleanUnion, and MergeAllFaces commands.

  2. Do you really need the columns to be in the analysis?

cleaned_master_plan.3dm (261 KB)


I will try to see if it works now, without the columns. I guess it was just for more precise results, you don’t think they matter ?