Problems with Honeybee simulation - GetSurfaceData: Errors discovered, program terminates

Hi everyone,

I started again to use HB and LB after a year and I found a lot of changes. As always when i create a new file I start to upload both of the plugin and till there everything works fine, but when i go on with creating stuff, the components gives to me a lot of different errors.

The first difference that I found is the icon of E+ Run Simulation is missing. Is it that ok? I thought that you guys have joined the components under the Open Studio Run Simulation component and so i used also that to run a simulation.

But the real problem that i have running a simulation is the following:

  1. Failed to parse the result file. Check the folder of the file address you are plugging into this component and make sure that there is a .csv file in the folder.
    If there is a file with no data in it (it is 0 kB), your simulation probably did not run correctly.
    In this case, check the report out of the Run Simulation component to see what severe or fatal errors happened in the simulation.
    If the csv file is there and it seems like there is data in it (it is not 0 kB), you are probably requesting an output that this component does not yet handle well.
    If you report this bug of reading the output on the GH forums, we should be able to fix this component to accept the output soon.

I serched into the folder but the file is there and its about 183kb so it shouldnt be empty. I also tried to give to the components E+ and OS run simulation another workingDir but the problem is still there.

The simulation anyway is running through the all year and if i connect a Panel in the output Result File Address it give me the directory of the folder where the file is.

I tried also with another document to run the analysis and i took an example file from hydrashare and in that case the simulation is running without problem.

In my file the problems are others, also with the Internal Mass component:

  1. Solution exception:Indice oltre i limiti della matrice.

That I solved just changing the component with a new one and its seems to work now, but everytime i open the document it gaves me the same error and i have to replace it.

Now I don’t know if the problem is my geometry that cause this problems or when i update the file. Can someone help me with it?

Thanks to everybody for your time. You are a great community.

Modello energetico (1.1 MB)

I’m sure a lot of people will be willing to help @AlessioMaurizi. For that i’ll recommend to upload the file you are trying to work on.

Hi @AbrahamYezioro, I tried also to upload the file here but the site gives me this “Sorry, new users can not upload attachments.” So actually I’m not able to upload the file I’m working with. Do you know how can solve it? :sweat:

Hmmm … No. For that the administrator need to give you the proper permissions.
I’m sure that by the end of the day @chrisor @mostapha will solve the issue.

Some minutes later I answered to you I got the upgrade to my profile. So I will upload the file below. :grinning::grinning:

@AbrahamYezioro you have the same admin privileges as I do and can change user trust levels to 1. basic-user. :slight_smile: @AlessioMaurizi should now be able to upload the files.

Hello everybody,

I was working in this days trying to fix the problems that I already explained, and I have to say something is moving!

First of all I was able to solve the problem of the Result File Missing, just copying the entire project that I created in a new document. Before to copy everything, I put the Ladybug_Ladybug and Honeybee_Honeybee components on the canvas and i updated all. After doing this my document worked well and the disappeared icon of E+ Run simulation came back, so I was able to run the analysis.

Than I found some other errors during the analysis and I edited my geometry trying to solve it. I found there were some geometries that were non convex and I found them with the component Find Non Convex.

I than tried to run the analysis of my geometry without adding glazing and everything worked well.

So now the new problems:

A. When I add glazing I got Fatal errors and E+ can’t run the analysis. I tried to solve this problem first checking the normal direction of the surfaces and I changed the direction of the ones that were wrong, but the error is still there.

So I tried to divide the window surfaces in 3 blocks of Surface component and tried to lunch the analysis, alternating the windows in the input of the component AddHBGlazing and I found that it run fine just with 1 of the 3 blocks.

The error that i get is this:

  1. The simulation has not run correctly because of this severe error:
    ** Severe ** checkSubSurfAzTiltNorm: Outward facing angle of subsurface differs more than 90.0 degrees from base surface.

  2. The simulation has failed because of this fatal error:
    ** Fatal ** GetSurfaceData: Errors discovered, program terminates.

As I said I checked every surface and fixed its normal. So I don’t know if the problem is different here.

B. In one of the different simulation that i runned i got another error that was:

  1. Solution exception:‘NoneType’ object has no attribute ‘split’.

C. The last error that i get always when i put TRUE to the Input write idf in the E+ run simulation component is this:

  1. Solution exception:Local variable ‘eioFileFullName’ referenced before assignment.

Can someone help me with this?

Sorry for the long post but I wanted to explain everything, so that it’s clear what I tried to do and what are my problems.

I also tried to clean as much as I could the file so you don’t get lost when looking at it.

Thanks again to everybody for your help!

Modello energetico (1005.4 KB)

@AlessioMaurizi ,

I’d recommend that you read the Ladybug Tools Forum Guidelines for advice on best practices for posting here. Notably, the “Don’t deviate too much” is relevant here are you have posted 3 different questions in one post. You also uploaded a 100+ zone model, which isn’t really following the guideline of “Only post relevant parts of your definition”.

For this reason, I will just answer your first question (the one that the title of this post refers to):
This was a bug that afflicted interior window surfaces of the last stable release of Honeybee. It has since been corrected in the version on the github:

Besides @chris’s answer to the issue of the internal windows, i recommend you to check your model on this respect.
As i can see, there a re a lot of internal windows standing alone. All types of windows (external and external) are hosted on walls. Many of your internals are not. Fix that and see what happens next.
I recommend you to start with a simplified model that have all situations of your model. Will be easier to debug, and once you do it will be much easier to implement in a more complex one.

@chris @AbrahamYezioro
Thank you for your answer. I’m really sorry that my first post was so far from the Forum Guidelines. If I can now do something to make the post more useful and more easy to read just let me know. I will fix it.

Anyway I will try to follow your advice and make some simulation with a simplified model, maybe just keeping some zones of my original file so I will be able to upload it here, if I still have problems.

Thanks again for your answer and again sorry


To add to @AbrahamYezioro comment about the interior windows. I see that you have interior windows on the intersect edge of the zones. This is why you get open breps after you add the windows. So, make sure to delete them or move them from the edge of interior zones. I hope this help you to start debug the model.

Hi guys,

I finally was able to solve the problem and now the simulation is running! So the problem was double:

  1. I checked the interior windows geometry and I recreated all of them, as suggested by @MohammedAlshayeb @AbrahamYezioro. When I was assigning this geometry, the brep that was coming out was open. So the problem was that the interior window should be in both of the adjacent surfaces that they touch, and the direction of their normal should be opposed. Probably I was just copying on place the geometry of the interior windows that I created for one surface, in the adjacent surface, without changing the direction of their normal, and it gave me a problem.

I was able to solve it thanks to an example that @chris shared in another post. Interior windows example
I exploded his window in the document and tried to copy the properties of it in my windows and this problem was fixed.


  1. The second problem was a trimmed surface with the component Intersect Mass. The component was working well but maybe the division that it made wasnt fine for E+. I can’t explain why it happened but I will share the cutted surface that didn’t work and the one that I divided manually:

I also tried to divide manually the geometry following the horizontal lines of the windows, but the only division that worked was the one that i show above in the MANUAL DIVISION.

Both of the problems were in conflict with the component add HBGlzing because the geometry without windows was running from the beginning. Should I change the title of the post in something more accurate? Let me know if it could be usefull for the future

Again thanks to everybody guys :wink:

@chris, I misread the title of your github post as “Greatly Cleaned Up OpenStudio Expert”. Nevertheless, I believe it is still accurate. :slight_smile:

No worries @AlessioMaurizi. Everyone learns at some point and I can imagine many people getting use out of this post to check that the bug with interior window surfaces has been fixed. In any case, glad that you solved your issues.

@Grasshope, yea, my github commit description could have been a lot less vague and harder to misinterpret. Thankfully, the OpenStudio experts I know are already pretty clean people :slight_smile:

A post was split to a new topic: Weather Simulation requested but no weather file attached