Problems with Radiation and Daylight factor

Dear all,

I’m performing radiation and daylighting analysis with Ladybug 1.6 tools. I had this strange warning error:

  1. Solution exception:The recipe failed to run with the following summary:

Scheduled 14 tasks of which:

  • 9 ran successfully:
    • 1 CopyGridInfo(…)
    • 1 CreateOctree(…)
    • 1 CreateRadFolder(…)
    • 1 CreateSky(…)
    • 1 CreateSkyDome(…)
  • 1 failed:
    • 1 AccumulateResultsLoop(…)
  • 4 were left pending, among these:
    • 1 were missing external dependencies:
      • 1 AccumulateResults(…)
    • 2 had missing dependencies:
      • 1 LetCumulativeRadiationFly(…)
      • 1 _Main_e9c43459Orchestrator(…)
    • 1 was not granted run permission by the scheduler:
      • 1 AccumulateResults(…)

This progress looks :frowning: because there were failed tasks

Use the report_out attribute of recipe settings to see a full report.

Any idea?

Thanks a lot,

Hi @angelo.figliola,

Are you able to share the log file? You should find it at the following path, or something similar to that.


logs.cfg (652 Bytes)
logs.log (80.9 KB)

Thanks for answering.

Here the files that I’ve found in the logs folder.

logs.cfg (650 Bytes)
logs.log (108.4 KB)

Hi @angelo.figliola,

Both of these show a successful run. If you are unsure which folder to look in please add a _folder_ to RecipeSetings.

Hi @mikkel , thanks for helping.

I’ve done what you suggested but I had tha same error that I posted yesterday.

In this case the DF analysis works but it’s not correct.

See the image.

Hi @angelo.figliola,

Is it possible for you to share the Grasshopper file with the geometry internalized so I can try to recreate the issue?

Hi @mikkel

Here the file. Thanks a lot
Error (268.4 KB)

Hi @angelo.figliola,

Thank you! The daylight factor issue is a modeling issue. The Apertures that you added to the model does not punch holes in the walls. You can do this by adding the Apertures as subfaces to the room. I have highlighted this in the attached Grasshopper file.
Error (277.3 KB)

The cumulative radiation issue is a bug in the recipe that has been there for some time now. Your room name has a space (which should be fine), but because the wrong key, “name”, is used instead of “full_id” it does not work. I pushed a fix for this and re-exported the recipe, which you should be able to get by updating your core libraries with LB Versioner.

1 Like

Dear @mikkel

First of all thanks for helping. I solved the issues with radiation analysis following your suggestion. When I’ve updated the file with LB Versioner the OpenStudio component stopped to work asking for the 3.51 version that I’ve installed without solving the problem. I never had before this kind of problem. Any suggestions?