Psychrometric Chart - Comfort polygon

I’m sorry for the lack of knowledge, I’m new to the tool and I’m still trying to get used to it, I’m following tutorials to understand the dynamics and concepts

My Psychrometric Chart
does not draw the polignos comfort

someone could help me figure out why this does not happen ?

my Rhino version is 6
LB 0.066 and HB0.063
Radience 5.1
Openstudio 2.4
LBNL Window 7.6
LBNL Therm 7.6

Psychrometric_Chart_Part_2.gh (461.3 KB)

@vinicius_petrucci
Your file works on my end with Rhino 5. I don’t have Rhino 6 to test it.

Thank you for the test, I’ll continue investigating.

McNeel has Rhino 5 access to Rhino 6 license users. There are other plugins that don’t work in Rhino 6 so McNeel gives access to its users.

https://www.rhino3d.com/access-rhino-5/win

So if you can not get it to work load it in Rhino 5

thanks for the tip I’m going back to rhino 5 I have other plugins that are not doing very well.

@vinicius_petrucci ,
Thanks for reporting this and it seems that one of the RhinoCommon methods that I was relying on to compute the comfort polygon in Rhino 5 has changed in Rhino 6. I’ll investigate this as soon as I get the chance and I’ve opened a github issue to make sure that the bug is fixed:

https://github.com/mostaphaRoudsari/ladybug/issues/438

@chris
Thank you very much for your attention.

@vinicius_petrucci ,

I just fixed the psych chart for Rhino 6:

You can find a working version of the sample file here:
Psychrometric_Chart_Part_2_FIXED.gh (550.8 KB)

It seems a lot of this had to do with Rhino 6 returning the results of trimming/splitting operations in a different order than it had done in Rhino 5, which is something that I should check for anyway.
Thanks again for reporting this!

Hi, I’m using Rhino 6. I just realized that only the “PsychChart” in your file is working, when I use this component from Ladybug, it is still not working.
Is it means that you’ve changed some code in your “PsychChart”?

thanks chris, your work has deal with my problem. but how can I change the component in ladybug?

Search for any of the forum discussions that ask how to sync your components with the github. There are components in Ladybug and Honeybee that let you update the components in your toolbar.

1 Like

Hi, I am facing the same issue as well with Rhino 7, tried to update the Ladybug component but it gives an error. May I ask how can I feed the sourceDirectory component? Can’t seem to find anything online. Thanks!

Unplug the sourceDirectory_

1 Like