Quality Views - View Analysis Not Working

I am trying to run a View Analysis, but I am getting no results, am I missing something? The visualization seems to not be getting anything.

quality_views.gh (190.8 KB)

The floor (the surface you want to check) is completely enclosed by the brep, so the results will be 100 (in your case, see below) or 0 for all grid points.
100 happens in your case because the normal direction of the floor points outside of the space, so it is completely unobstructed.
0 if you flip the normal direction (as it should be), but because of what i said at first, the grid points are blocked by the space boundaries.
-A.

1 Like

@AbrahamYezioro thank you so much for your reply!

So what I am trying to achieve, is LEED V4.1 Quality Views credit that establishes “Provide occupants in the building with a view to the outdoor natural or urban environment for 75% of all regularly occupied floor area.” and that is it.

So wouldn’t I need to enclose the surface I want to check (which is the floor area) with all the walls that would be blocking the view to the outside? I left a window area unmarked, but it does not even take that into consideration?

I recommend to check the example in hydra that shows how to evaluate an internal space regarding he view to the outside (not for LEED).
It is a Legacy example but the principle is there and i’m sure you’ll manage.
Please report your advances on this.
-A.

The hydra example doesn’t work as expected in Rhino 7. But if you just use the ViewPercent of LBT it is pretty much straight forward to make it work.
-A.

@AbrahamYezioro I did use the ViewPercent of LBT, if you want to check, the file is attached in my explanation post like the first on of this topic. Am I missing something in that script that is stopping it from working the way is supposed to?

You need to have the window hole in the facade (no window geometry).
I would also rise a bit the test surface to head height.
-A.

Hi.

Were you able to find a solution to this? it doesnt seem to be working for me either. I even tried the sample file from hydra and even that is showing me 0% views.

Edit: Nevermind. It doesnt work on Rhino 7. Have to use Rhino 6 for it.

Yes, I just had to elevate the test surface to 6’ and it worked ok. Now I’m having other types of issues with it, such as the new version not automatically transforming meshes to surfaces.