Question on Outdoor airflow


#1

Hi Mostapha et al.
Me again. I took Mostapha’s outdoor airflow example and applied to my urban site. In the example file, the airflow in horizontal plane was beautifully simulated so I can see the airflow pattern around buildings. But in my urban site where I modified the size of bounding boxes of a wind tunnel and analysis plane, the airflow didn’t address buildings and linearly simulated as shown in attached image. Is there anything that I missed?
Your input will be greatly appreciated.


#2

Hi, @maftokki
It is hard to understand your question.Please upload your rhino model and grasshopper defintion.


#3

Hi Minggangyin,
Thank you for reply.
Please find the attached zip files for your reference.
An attached image is what I could get from Mostapha’s example file and do want to get.

Thank you for your help in advance. 01_0_outdoor_airflow-Rev for Site.zip (598.8 KB)


#4

From this screenshot it looks like you haven’t removed the points inside the buildings and that causes all the extra vectors collected in the last point in the visualization.


#5

Mostapha,
Thank you for your input. If you don’t mind, can you guide me how to remove the points inside the buildings? I couldn’t find any tips in your tutorials.
Appreciated your help!


#6

I had the same problem weeks ago.
Looks like snappyhexmesh componenti is not in your code.
snappyHexMesh makes the mesh snap onto the geometry. I suggest you to check mostapha sample codes. Have also a look at this:


Hope It helps
Alberto


#7

Please offset the analysis surface by the distance equal to at least the lowest mesh size (mostly 1 meter). That should make sure that no probes are inside the buildings.


#8

Thank you, all!
As suggested I checked the version (ver 0.0.04 MAR_14_2017, right?) and reloaded snappyHexMesh.
Also made sure the analysis surface is offset at least 1 meter.
But as you see in the attached images, I still have that issue.
When I tested the same GH with the relatively smaller urban setting that has 5 buildings within 50m x 50m, it worked. But the bigger one didn’t work correctly.
Is the different component required for the bigger context?

Thank you for your help again!


#9

Hi @maftokki

I think SHM still didn’t happen. The usual reason for it is that your total cell count allowed (the input in the SHM dict component) is too small, in fact smaller than what your blockMesh potentially is. In that case, OF will fire up SHM, count the total cells in your blockMesh, compare them against your maximum allowed, and if the second is smaller than the first, skip meshing completely.

Try increasing that and see what happens. If you upgrade to the latest BF, there is a gradient mesh component I highly recommend using (it makes decent meshes with minimal supervision). In that component you get an output of your total cell count in the blockMesh. I would multiply that by 5 and input that number to the total number of cells input in the SHMDict component.

Hope this helps.

Kind regards,
Theodore.


#10

TheodorosGalanos,
Thank you for feedback,
I bipmed up the numbers as you suggested, but no luck…
Can you let me know where I can find the gradient mesh component plese?
I have BF 0.0.04 but couldn’t find it.
Thank you!