RAD material problem

Hi everyone,

I have worked with DIVA for Rhino and already tried DIVA for GH, but I just started. Now I want to use Honeybee for more controlled simulations. In DIVA for GH there is no problem using the material from C:\DIVA\Daylight\material.

In Honeybee I wasn’t able to import this RAD file. I had to add every material with the addtolibrary component.

Yesterday, HB told me about the new version, so I’ve done the update. Looks like there are some very helpful new tools… but I can’t get HB to fly (Ladybug flies).

The addto/callfromlibrary component says:

  1. Solution exception:honeybee_RADMaterialAUX

Never had this Problem before and I don’t know how to solve it.

Please, can you help?

Jakob

Jakob,

Try copy/paste the materials from the DIVA file to the HoneybeeRadMaterials.mat file, usially locates at c:\ladybug.

-A.

Hi Jacob,

Have you changed the source code? By default Honeybee should not be importing materials from Diva.

In honeybee you can copy all your custom materials to (ladybugFolder\HoneybeeRadMaterials.mat). Make sure to leave an empty line between each two materials.

Back to the error if you upload the material.RAD file here I can tell you why Honeybee can’t import the material from your file.

Mostapha

Hi,

I haven’t changed the source code, at least not consciously.

The material.RAD is the standard file from DIVA.

I removed HB+LB and put them in again, problem stays the same.

This cracks me up, do I have to reinstall Grasshopper? If so, how to do this properly?

Jakob

I don’t have DIVA so I need your file to give it a try.

I don’t think reinstalling helps. We should figure out why the component is even trying to import the file in the first place.

Mostapha

This is the file.

material.rad (6.85 KB)

I tried the file and I can’t recreate the problem. It imports all the materials with no issues. Can you try the attached file and let me know if it works for you?

importRadIssue.gh (433 KB)

Mostapha, I tried too and I couldn’t recreate it either…by the way, do you know why is Honeybee reading the file Material.rad from C:\Diva\Daylight in the first image ?

Attached file didn’t work either.

I changed the default folder to C:\Ladybug and it works!

But C:\Users\username\AppData\Roaming\Ladybug doesn’t (shows C:\Diva\Dayl… error).

How can I set the default folder to C:\Ladybug as standard?

Importing materials is also no longer a problem.

Thank you for your time. I appreciate your work very much and I hope next time I will ask something more important.

-Jakob

That’s what I’m trying to figure out too. The library name is explicitly set: os.path.join(self.HoneybeeFolder, “HoneybeeRadMaterials.mat”

Thanks Jacob for reporting back. Can you share with me the initial file? By checking the line numbers we should be able to find why this issue is happening at the first place.

The HoneybeeScript?

HoneybeeScript.py (352 KB)