Radiance 5.3 falsecolor legend Working Hack

quick hack to get the false color component from Honeybee Legacy working with radiance 5.3

Everything works almost the same, just a couple of changes on the batch file command.
Before that, to get around compatibility checks in the Honeybee+ component go ahead and change line 137 from:
if not os.path.isfile(hb_RADPath + “\falsecolor2.exe”):
if not os.path.isfile(hb_RADPath + “\falsecolor.exe”):

line 162 change into : “SET PATH=%PATH%;” + hb_RADPath + “\n”

between lines 163 and 174, when defining “batchStr_body”, just change every call to “falsecolor2” into “falsecolor”

get rid of legend position flag , line 175 to 177 ish. I think -lp may be gone in the new falsecolor.exe.

around line 185, have batchStr as follows (get rid of the “z” flag):
batchStr = batchStr_head + batchStr_body + " > " + outputFile + “\nexit”



auto scaling is not working for me. it is supossed to have changed from -s auto to -s a but it doesn’t work in my computer. I’m having to play around with legendMax values otherwise I get a monochrome output with scale 0 -1.

Colors are different now and to use alternate schemes “-spec” becomes “’-pal” + spec or eco or hot

Thank you for your hack Mauricio, but the LB viewer cannot find the GIF file that already exists, Any solution?
Thanks in advance

Hi Patricia,

I don’t know specifically what is happening with the LB viewer.
Is the hacked false color component producing a valid image that you can open through file explorer?

If you attach your script I can have a look and test it on my computer.

Hi Mauricio, I just had an old falsecolor.exe from 2013! I´m simulating before HB-LB exists. Now it works. Thank you for your soon response!

Good to know it’s working now. Glad to be of help.
best wishes,

Hi Patricia,

Could you please share the exe file? I have the same issue.

Hi Ranjitha,
Cannot upload it, it exceeds the allowed maximum

Honeybee_FalseColor.ghuser (7.4 KB)
try this

Thanks Patricia, I still have the issue. I have the Radiance version 5.4a installed.
I am getting the following error:

  1. Cannot find falsecolor2.exe at c:\radiance\bin\Make sure that falsecolor2 is installed on your system.
    I will try Mauricio’s batch file command chages.

The LBT 1.3 version have updated false color which works with Radiance 5.4a. I recommend using LBT version rather than legacy version.

you can google me and send me an email
Patricia Camporeale

Hey, this worked. Thank you so much!