Radiance Error - rtrace fatal - command line error at '-c'

Dear LB community,

I have recently updated my LB tools to version 1.8.0, however, after doing so I have encountered some simulation errors.

When running an old daylight factor script, which was running perfectly previously, I get this error message:

I’ve uninstalled LB tools, radiance, openstudio etc. and both tried to install everything separately using the compatibility matrix and using the one click pollination installer, but nothing seems to work. I’ve made sure everything is in the same folder (C:\Users[MyUserName]\ladybug_tools) and unblocked any Windows security blocking it.

I have read multiple threads and tried so many different things the past few days, but I really can’t figure out what the issue seems to be.

Any suggestions are very much appreciated.


I’ve uploaded the GH script and a screenshot of queenbee.exe right before the simulation seems to stop:

HB template_daylight_St.Kongensgade67C.gh (690.7 KB)

Hi @Madskj ,

Please be better about only supplying minimal sample files next time but what you supplied was enough for me to see what you did wrong. It has nothing do do with upgrading to LBT 1.8.

The mistake you made was connecting Radiance Parameters for an annual (rfluxmtx) simulation instead of a daylight-factor (rtrace) simulation:

Just change this to be for the correct Radiance simulation type and it will run:

Hi @chris

I’m so sorry about the large sample file. Thank you for pointing out the mistake; it was a complete lapse on my part. All of my simulations had issues after updating to the newest version, and when some of them finally worked and the DF didn’t, I gave in and made a post.

As a long-time user, I want to say thank you for the work you guys put into this amazing tool!

All the best,

1 Like