Radiation using Radiance Errors

Hi all

Not sure how to describe as it just doesn’t work

The surface by surface daylight analysis script supplied is where I’ve tried to analyse a brep and it seems to only want to analyse one surface, disperse the test points in an awkward manner, and finally give no result.

Help, please!

.gh file is here:

Many thanks

Hi @leonardo.ali,

I recommend you take a look at https://www.youtube.com/watch?v=M4MA82_CPPA&list=PLkjfDmSc5OryXkWSt57ltJFU4qXD5ss1v series. It will answer all of your questions

Hi @devang, thank you so much for the quick reply!

I’ve watched these videos before and still feel the setup of the script is in tact.

I’m not sure if its any of the Radiance/Daysim stuff that is setup strange because I keep getting error logs in the cmd.

Can I ask if the script works with you?


The script works just fine at my end. So yes, I could be an installaton issue The log error should go away after a restart.

Restarted and still failing… system goes down with Not Responding and cmd reports this. Is it anything to do with the location of the files? They’re all on the C Drive as advised

this is all I get from the result too, also to mention I’ve checked the direction of the normals that are correct. should be the whole envelope and not just one surface?

Can you please disconnect 4000 value from the highBound_ on the legendPar component?

To get better points, I would suggest you rotate your building to align with x axis and rotate the north.

Please try this file;
Daylight_HoneyBee_Surface_by_Surface.gh (1.1 MB)

You should rotate the north in the file.

@devang thanks for the amendments! two things:

A) why/how do I need to rotate it? Do I need to suggest where north actually is somewhere else in the script?
B) I assume all I had to do was run the script and I would see as your screenshot? If so, then mine doesn’t produce any results, just the baked geometry…

I stand corrected. The cumulative sky does not have north input so the geometry cannot be rotated.
Yes. Your model works fine at my end.

does this mean there could be something wrong with the installation of files? how can I check?

Can you please share the error message / s?

the error message is blank, if we’re referring to ‘read me’

otherwise, the only warning is in honeybee:

Can you please try the file in Meters?

Also, please update your Ladybug Installation. You are using components from 2018.

who knew… using the most up-to-date version would make it work… thank you very much! it worked. note: I didn’t need to do anything to units

THANKS :smiley: