Recipe issues v1.4.0

Hi Team,

Nick from COREstudio here. Recently upgraded to latest release and am getting some consistent errors with recipe creation in annualdaylight and solarradiation study examples. Model creation is no problem, and Ladybug sample files are

I’ve verified the install and versions (via HBConfig etc), and the tried a clean sweep then reinstall, but run into the same issue when attempting to run the daylight analysis sample file. Get’s through to CreateSunPath and fails. Feel like it’s something simple I’m missing but have been unable to find the casue.

image

In the radiation study example the error traces back to line 149 in the LBIncidentRadiation component;

mesh the geometry and context

shade_mesh = join_geometry_to_mesh(_geometry + context_)

# deconstruct the matrix and get the sky dome vectors
mtx = de_objectify_output(_sky_mtx)
total_sky_rad = [dir_rad + dif_rad for dir_rad, dif_rad in zip(mtx[1], mtx[2])]
ground_rad = [(sum(total_sky_rad) / len(total_sky_rad)) * mtx[0][1]] * len(total_sky_rad)

Any help much appreciated.

Cheers
Nick

Hello to all,

I am having the same issue with HB recipes. I tried with Annual Daylight and HB Point-in-Time Grid-Based recipes and give me the same error every time.

I tried with the file that is provided with the installation folder and another one following the video tutorials provided by Ladybug Tools in YouTube.

I ran LB Versioner and LB Sync Grasshopper File and uninstall and reinstall LBT and is giving me the same error every time.

I have read all the similar posts I have found about this problem, but I can not find a proper solution.

Thanks in advance.

annual_daylight.gh (82.2 KB)

The Luigi log file error:

Luigi Task Visualiser.mhtml (449.2 KB)

Hey @jorgeallen and @nick ,

I am unable to recreate the issue on my end using your sample file:

It appears that all steps of the recipe are failing for you so there’s a pretty big issue with your installation. Are you not even able to run the HB Check Scene component? If so, that means there’s probably something really wrong with your Radiance installation. I might recommend using the single-click Pollination Grasshopper installer to install Ladybug Tools instead of the installation route that you are using now.

Hello @chris ,

Thanks for taking the time to review the definition and respond. I performed the procedure you tell me, and the versions of the plugins are the same as those indicated in the Ladybug installation instructions. The HB Check Scene component throws me a couple of errors in these files: util.py and command.py

I will try to install everything again and try to fix the error. I’ll keep you posted. I see that several users have had the same problem.

Thank you.

@chris ,

I finally found the issue that caused the error when running the recipes. I must run Rhino as Administrator and that was it. I don’t know why Rhino was not running as Admin, or how it was running.

Anyway, thanks again for your reply. Maybe this solution helps other users that find themselves in the same situation.

1 Like

Hi @jorgeallen ,

By default, Rhino does not run as Admin and you usually should not have to do this. However, it sounds like your IT department has put some heavy restrictions on your machine and so I have a suggestion that might prevent you from needing to run Rhino as Admin:

Just install Ladybug Tools using the free single-click Pollination installer that you can find here. You will need to create a Pollination account to get the installer but, because it installs everything (including Radiance) using Admin privileges, this should prevent you from needing to run Rhino as Admin every time that you want to use Radiance.